summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2023-01-15 13:55:17 +1300
committerMichael Orlitzky <mjo@gentoo.org>2023-01-16 18:20:11 -0500
commit08fd3aa913284cddc9f861e9b27b0087455d827d (patch)
tree6221de2f3b8384bd1a1c3bfee4587f32d46f5167 /sci-libs/brial
parentdev-util/ostree: use tmpfiles.eclass (diff)
downloadgentoo-08fd3aa913284cddc9f861e9b27b0087455d827d.tar.gz
gentoo-08fd3aa913284cddc9f861e9b27b0087455d827d.tar.bz2
gentoo-08fd3aa913284cddc9f861e9b27b0087455d827d.zip
sci-libs/brial: add 1.2.12
Closes: https://github.com/gentoo/gentoo/pull/29111 Closes: https://bugs.gentoo.org/890425 Signed-off-by: Michael Orlitzky <mjo@gentoo.org> Signed-off-by: François Bissey <frp.bissey@gmail.com>
Diffstat (limited to 'sci-libs/brial')
-rw-r--r--sci-libs/brial/Manifest1
-rw-r--r--sci-libs/brial/brial-1.2.12.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/brial/Manifest b/sci-libs/brial/Manifest
index 4f4cb180b5a0..1f444c0b51e5 100644
--- a/sci-libs/brial/Manifest
+++ b/sci-libs/brial/Manifest
@@ -1 +1,2 @@
DIST brial-1.2.11.tar.bz2 1260892 BLAKE2B 910f4ffd728235c8b18deb0d36c76778ce2c392644b7eaba06a9c00a832b4ccb0c2cd69f4d9ab9770e060b54491bd6b613e4e1324a32f57d7c32f200fb0a900d SHA512 00532b6361c709fce44940bfd22563046cfcbc06d41282a01a26f9bcb25fa86df1406685d7ba4b1ebbb08cd7fa8b9811c81eccf78e72ea96960ef7a059c2e926
+DIST brial-1.2.12.tar.bz2 1259569 BLAKE2B bf9415b2980d76d00239eceea113d6dbb916f5dcec3bdecb05db0ad1988761e4d25ab9a0419c68a3b2501f1f9dc6e2d31418aea7c727cfd01f4ae76eea8f81e2 SHA512 c44902f0f935d614b8c2d437d6c895f650ff4b77501ac3ba035e21671719f4080c88a173819f8db8e8b7dda121736146d8388b70ad7cda75207a1b22b93f5af6
diff --git a/sci-libs/brial/brial-1.2.12.ebuild b/sci-libs/brial/brial-1.2.12.ebuild
new file mode 100644
index 000000000000..31821f7a6cde
--- /dev/null
+++ b/sci-libs/brial/brial-1.2.12.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A C++ library for polynomials over boolean rings"
+HOMEPAGE="https://github.com/BRiAl/BRiAl"
+SRC_URI="https://github.com/BRiAl/BRiAl/releases/download/${PV}/${P}.tar.bz2"
+
+# The top-level license is GPL2+, but cudd/LICENSE is BSD.
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="png"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/boost
+ sci-libs/m4ri[png=]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ tc-export PKG_CONFIG
+
+ # with-boost-libdir added to deal with some rather quirky setups
+ # see https://github.com/cschwan/sage-on-gentoo/issues/551
+ econf \
+ --with-boost="${ESYSROOT}"/usr \
+ --with-boost-libdir="${ESYSROOT}"/usr/$(get_libdir)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}