summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2022-07-30 21:30:09 +1200
committerMichael Orlitzky <mjo@gentoo.org>2022-08-03 16:21:55 -0400
commit6160b92370642d2651838022251ef6b2f27e7aed (patch)
tree9f24b3d6036675c0b4ec23a48e206c0c017246bd /sci-libs/brial
parentsys-kernel/gentoo-kernel-bin: Bump to 5.15.59 (diff)
downloadgentoo-6160b92370642d2651838022251ef6b2f27e7aed.tar.gz
gentoo-6160b92370642d2651838022251ef6b2f27e7aed.tar.bz2
gentoo-6160b92370642d2651838022251ef6b2f27e7aed.zip
sci-libs/brial: upstream bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: François René Pierre Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/brial')
-rw-r--r--sci-libs/brial/Manifest1
-rw-r--r--sci-libs/brial/brial-1.2.11.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/brial/Manifest b/sci-libs/brial/Manifest
index 07e518dcc825..dc8bb220205e 100644
--- a/sci-libs/brial/Manifest
+++ b/sci-libs/brial/Manifest
@@ -1 +1,2 @@
DIST brial-1.2.10.tar.bz2 1229830 BLAKE2B a1cfe4fcd19824d04388bbab1130a9d07e5920fb05ea1686424f1e0193c6f5d29300bba66bdf7ac59665cbceed3f6ff84fbb5a95311858196a0fbdecda5a2cc7 SHA512 163d9f3703271f412d20ec165d713280d9b46c50b66eed0b15385c6d94569e0ea5d7e84c3b6715d51197e97be4062325551402c844f70235a4aa1cebc5e9d3a1
+DIST brial-1.2.11.tar.bz2 1260892 BLAKE2B 910f4ffd728235c8b18deb0d36c76778ce2c392644b7eaba06a9c00a832b4ccb0c2cd69f4d9ab9770e060b54491bd6b613e4e1324a32f57d7c32f200fb0a900d SHA512 00532b6361c709fce44940bfd22563046cfcbc06d41282a01a26f9bcb25fa86df1406685d7ba4b1ebbb08cd7fa8b9811c81eccf78e72ea96960ef7a059c2e926
diff --git a/sci-libs/brial/brial-1.2.11.ebuild b/sci-libs/brial/brial-1.2.11.ebuild
new file mode 100644
index 000000000000..b744da836a67
--- /dev/null
+++ b/sci-libs/brial/brial-1.2.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A C++ library for polynomials over boolean rings"
+HOMEPAGE="https://github.com/BRiAl/BRiAl"
+SRC_URI="https://github.com/BRiAl/BRiAl/releases/download/${PV}/${P}.tar.bz2"
+
+# The top-level license is GPL2+, but cudd/LICENSE is BSD.
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="png static-libs"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/boost
+ sci-libs/m4ri[png=]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ tc-export PKG_CONFIG
+
+ # with-boost-libdir added to deal with some rather quirky setups
+ # see https://github.com/cschwan/sage-on-gentoo/issues/551
+ econf \
+ --with-boost="${EPREFIX}"/usr \
+ --with-boost-libdir="${EPREFIX}"/usr/$(get_libdir) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}