summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2022-08-16 07:31:00 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2022-08-16 07:31:00 +0200
commit5c049c6bc4dd4e88c6872a372d83f7358b09f0f0 (patch)
treec50f3c5166cf25a6ef7d76f148ac1120f5fe7f99 /sci-libs/cartopy
parentx11-wm/cwm: Stabilize 7.1 amd64, #865305 (diff)
downloadgentoo-5c049c6bc4dd4e88c6872a372d83f7358b09f0f0.tar.gz
gentoo-5c049c6bc4dd4e88c6872a372d83f7358b09f0f0.tar.bz2
gentoo-5c049c6bc4dd4e88c6872a372d83f7358b09f0f0.zip
sci-libs/cartopy: add 0.20.3
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'sci-libs/cartopy')
-rw-r--r--sci-libs/cartopy/Manifest1
-rw-r--r--sci-libs/cartopy/cartopy-0.20.3.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sci-libs/cartopy/Manifest b/sci-libs/cartopy/Manifest
index 4e9c493bc31c..9aa60979e409 100644
--- a/sci-libs/cartopy/Manifest
+++ b/sci-libs/cartopy/Manifest
@@ -1,2 +1,3 @@
DIST cartopy-0.20.1.tar.gz 10704635 BLAKE2B 29ff571a4dccfe71585d6da4d11730fdb7d1b4bf28e9e16a7e928dc154a1fb74169fb122bf9dd2ebbc8b1a3d2ff4cd4591ec2afaa7eb9728ce1ae8a66facff1c SHA512 fe846fcaa8860f5bee4c478aa8a2125dad19d0d7988d10ee587590834728708f2a015104852d4320ba4d2367b78bad36cbdaa2b48cb6ed5b7b4d4e06a86e20d2
DIST cartopy-0.20.2.tar.gz 10703222 BLAKE2B 18763971b33704c526bc98dede60077382de1e6855bd5dcc8901d729b9400eb2a3fdb2e6e2bd9b705ad2d43ab089e4837f12b7dc465429f1cdede21f174f8ef4 SHA512 1208c11a4b6d4b01b7ed7459ced7d79b0b60abc7be0f88562aa0d3826ac6bcebfe51cdf68213fd668353f4c269eb2c10fc2bf15e9db0b4c5802f629b76be3761
+DIST cartopy-0.20.3.tar.gz 10703747 BLAKE2B 794b0e837893c99bec54423731993a0321f3bd93a01bcc9c1ccfd056d4739d7f4b687c0c05e5e529edd8b350478dc76ccf9f3163061466ee6711949f360f7e7b SHA512 0ac4722ed541d77ac871438b2f4e5252c8ae0ab0551bd62a8ba654e10183bba2f702d70cc7331f1cce488c0a59fe4d24e7009de25d74a563f3b2763a12c504dd
diff --git a/sci-libs/cartopy/cartopy-0.20.3.ebuild b/sci-libs/cartopy/cartopy-0.20.3.ebuild
new file mode 100644
index 000000000000..8748a3e391ab
--- /dev/null
+++ b/sci-libs/cartopy/cartopy-0.20.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1 virtualx
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Python package for geospatial data processing and analysis"
+HOMEPAGE="https://scitools.org.uk/cartopy"
+SRC_URI="https://github.com/SciTools/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ sci-libs/geos
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/pyshp[${PYTHON_USEDEP}]
+ dev-python/shapely[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/pillow[jpeg,${PYTHON_USEDEP}]
+ sci-libs/gdal[python,${PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ >=sci-libs/proj-8
+"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+DEPEND+="test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/flufl-lock[$PYTHON_USEDEP]
+ )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_prepare_all() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+ # drop test file requiring network access, which got not covered by markers
+ rm "${S}"/lib/cartopy/tests/mpl/test_crs.py || die
+ rm "${S}"/lib/cartopy/tests/mpl/test_gridliner.py || die
+ # prepare matplotlib backend for test suite
+ export MPLCONFIGDIR="${T}"
+ echo "backend : Agg" > "${MPLCONFIGDIR}"/matplotlibrc || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"
+ # drop all tests needing network access
+ virtx pytest -vv -m "not network and not natural_earth" || die "test failed"
+}