summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-15 09:42:46 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-15 09:42:46 +0100
commitaa1e1f9c506b061f3eebb10304560bff038731b6 (patch)
tree8b41899982823343a2f4f08cf9a800a49f3b0690 /sci-libs/ccfits
parentsci-mathematics/4ti2: Port to EAPI 7 (diff)
downloadgentoo-aa1e1f9c506b061f3eebb10304560bff038731b6.tar.gz
gentoo-aa1e1f9c506b061f3eebb10304560bff038731b6.tar.bz2
gentoo-aa1e1f9c506b061f3eebb10304560bff038731b6.zip
sci-libs/ccfits: Port to EAPI 7
Bug: https://bugs.gentoo.org/770637 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/ccfits')
-rw-r--r--sci-libs/ccfits/ccfits-2.5.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/sci-libs/ccfits/ccfits-2.5.ebuild b/sci-libs/ccfits/ccfits-2.5.ebuild
index d02029f57d00..c2dbe59e5bce 100644
--- a/sci-libs/ccfits/ccfits-2.5.ebuild
+++ b/sci-libs/ccfits/ccfits-2.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools eutils ltprune
+inherit autotools
MYPN=CCfits
MYP=${MYPN}-${PV}
@@ -15,17 +15,15 @@ SRC_URI="https://heasarc.gsfc.nasa.gov/fitsio/CCfits/${MYP}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc static-libs"
+IUSE="doc"
RDEPEND=">=sci-libs/cfitsio-3.080"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MYPN}"
-DOCS=( CHANGES README.INSTALL )
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2-makefile.patch # avoid building cookbook by default and no rpath
-)
+# avoid building cookbook by default and no rpath
+PATCHES=( "${FILESDIR}"/${PN}-2.2-makefile.patch )
src_prepare() {
default
@@ -34,7 +32,7 @@ src_prepare() {
}
src_configure() {
- econf $(use_enable static-libs static)
+ econf --disable-static
}
src_install() {
@@ -43,5 +41,6 @@ src_install() {
HTML_DOCS=( html/. )
fi
default
- use static-libs || prune_libtool_files --all
+
+ find "${ED}" -name '*.la' -delete || die
}