summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-29 03:13:01 +0100
committerSam James <sam@gentoo.org>2021-07-29 03:13:25 +0100
commit2cdd21f573f85820be43dc8e2ca44730c269dcbe (patch)
treedcbe4a725aaa84f4c29295861b3a598a9f90841b /sci-libs/cdf
parentsci-libs/cdf: fix docinto argument (avoid double 'prefix') (diff)
downloadgentoo-2cdd21f573f85820be43dc8e2ca44730c269dcbe.tar.gz
gentoo-2cdd21f573f85820be43dc8e2ca44730c269dcbe.tar.bz2
gentoo-2cdd21f573f85820be43dc8e2ca44730c269dcbe.zip
sci-libs/cdf: fully respect AR, CC
We were calling AR directly but also 'gcc' as LD. Let's just use $(tc-getCC) as LD given that's now the recommended way to call the linker, and indeed, we use incompatible arguments for ld anyway. Closes: https://bugs.gentoo.org/725444 Closes: https://bugs.gentoo.org/792990 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/cdf')
-rw-r--r--sci-libs/cdf/cdf-3.8.0-r1.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/sci-libs/cdf/cdf-3.8.0-r1.ebuild b/sci-libs/cdf/cdf-3.8.0-r1.ebuild
index 000c1d62d1a9..5d8499adc51c 100644
--- a/sci-libs/cdf/cdf-3.8.0-r1.ebuild
+++ b/sci-libs/cdf/cdf-3.8.0-r1.ebuild
@@ -59,7 +59,9 @@ src_compile() {
PV_SO=${PV:0:1}
emake \
OS=linux \
+ AR=$(tc-getAR) \
CC=$(tc-getCC) \
+ LD=$(tc-getCC) \
ENV=gnu \
SHARED=yes \
SHAREDEXT_linux=so.${PV_SO} \