summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-07-27 22:33:32 -0400
committerAaron Bauman <bman@gentoo.org>2020-07-27 22:33:32 -0400
commitf63396228c129fdbac0b2b6bf90ca0dbe64bfb08 (patch)
tree7f870e5b96903f3fd9ebe72e4da5188f7092f94d /sci-libs/chemkit/files
parentapp-misc/OpenRGB-0.3-r1: Revbump, add udev USE flag to install udev rules (diff)
downloadgentoo-f63396228c129fdbac0b2b6bf90ca0dbe64bfb08.tar.gz
gentoo-f63396228c129fdbac0b2b6bf90ca0dbe64bfb08.tar.bz2
gentoo-f63396228c129fdbac0b2b6bf90ca0dbe64bfb08.zip
*/*: Drop last-rited Py2 only pkgs
Bug: https://bugs.gentoo.org/616064 Closes: https://bugs.gentoo.org/721904 Closes: https://bugs.gentoo.org/609686 Closes: https://bugs.gentoo.org/695016 Closes: https://bugs.gentoo.org/722616 Closes: https://bugs.gentoo.org/684098 Closes: https://bugs.gentoo.org/672164 Closes: https://bugs.gentoo.org/699136 Closes: https://bugs.gentoo.org/690776 Closes: https://bugs.gentoo.org/695912 Closes: https://bugs.gentoo.org/697004 Closes: https://bugs.gentoo.org/711026 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'sci-libs/chemkit/files')
-rw-r--r--sci-libs/chemkit/files/chemkit-0.1-multilib.patch90
-rw-r--r--sci-libs/chemkit/files/chemkit-0.1-unbundle.patch191
2 files changed, 0 insertions, 281 deletions
diff --git a/sci-libs/chemkit/files/chemkit-0.1-multilib.patch b/sci-libs/chemkit/files/chemkit-0.1-multilib.patch
deleted file mode 100644
index b6a61d58ed8c..000000000000
--- a/sci-libs/chemkit/files/chemkit-0.1-multilib.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index e531be4..e0d6b2d 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -44,7 +44,7 @@ configure_file(
- "${CMAKE_MODULE_PATH}/ChemkitConfig.cmake.in"
- "${CMAKE_BINARY_DIR}/ChemkitConfig.cmake"
- IMMEDIATE @ONLY)
--install(FILES ${CMAKE_BINARY_DIR}/ChemkitConfig.cmake DESTINATION lib/chemkit)
-+install(FILES ${CMAKE_BINARY_DIR}/ChemkitConfig.cmake DESTINATION lib${LIB_SUFFIX}/chemkit)
-
- # Create a ChemkitBuildTreeSettings.cmake file for the use from the build tree
- configure_file(
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 88c6b5f..1100c3b 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -8,12 +8,12 @@ macro(add_chemkit_library library_name)
- add_library(${library_name} SHARED ${ARGN})
-
- # add install target
-- install(TARGETS ${library_name} DESTINATION lib)
-+ install(TARGETS ${library_name} DESTINATION lib${LIB_SUFFIX})
-
- # copy library into build directory
- get_target_property(library_location ${library_name} LOCATION)
- get_filename_component(library_filename ${library_location} NAME)
-- add_custom_command(TARGET ${library_name} POST_BUILD COMMAND ${CMAKE_COMMAND} ARGS -E copy ${library_location} ${CMAKE_BINARY_DIR}/lib/${library_filename})
-+ add_custom_command(TARGET ${library_name} POST_BUILD COMMAND ${CMAKE_COMMAND} ARGS -E copy ${library_location} ${CMAKE_BINARY_DIR}/lib${LIB_SUFFIX}/${library_filename})
-
- endmacro(add_chemkit_library)
-
-diff --git a/src/plugins/CMakeLists.txt b/src/plugins/CMakeLists.txt
-index dc8970f..77029b7 100644
---- a/src/plugins/CMakeLists.txt
-+++ b/src/plugins/CMakeLists.txt
-@@ -3,7 +3,7 @@ macro(add_chemkit_plugin plugin_name)
- add_library(${plugin_name} SHARED ${ARGN})
-
- # add install target
-- install(TARGETS ${plugin_name} DESTINATION lib/chemkit/plugins/)
-+ install(TARGETS ${plugin_name} DESTINATION lib${LIB_SUFFIX}/chemkit/plugins/)
-
- # remove 'lib' prefix
- set_target_properties(${plugin_name} PROPERTIES PREFIX "")
-@@ -11,15 +11,15 @@ macro(add_chemkit_plugin plugin_name)
- # copy plugin into build directory
- get_target_property(plugin_location ${plugin_name} LOCATION)
- get_filename_component(plugin_filename ${plugin_location} NAME)
-- add_custom_command(TARGET ${plugin_name} POST_BUILD COMMAND ${CMAKE_COMMAND} ARGS -E copy ${plugin_location} ${CMAKE_BINARY_DIR}/lib/chemkit/plugins/${plugin_filename})
-+ add_custom_command(TARGET ${plugin_name} POST_BUILD COMMAND ${CMAKE_COMMAND} ARGS -E copy ${plugin_location} ${CMAKE_BINARY_DIR}/lib${LIB_SUFFIX}/chemkit/plugins/${plugin_filename})
-
- # plugin data
- if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/data)
- # copy plugin data into build directory
-- file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/data/ DESTINATION ${CMAKE_BINARY_DIR}/lib/chemkit/plugins/data/${plugin_name}/)
-+ file(COPY ${CMAKE_CURRENT_SOURCE_DIR}/data/ DESTINATION ${CMAKE_BINARY_DIR}/lib${LIB_SUFFIX}/chemkit/plugins/data/${plugin_name}/)
-
- # install plugin data directory
-- install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/data/ DESTINATION lib/chemkit/plugins/data/${plugin_name})
-+ install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/data/ DESTINATION lib${LIB_SUFFIX}/chemkit/plugins/data/${plugin_name})
- endif()
- endmacro(add_chemkit_plugin)
-
-diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
-index b191b82..a4ea0b0 100644
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -4,7 +4,7 @@ endif()
-
- macro(add_chemkit_test test_name test_executable)
- add_test(NAME ${test_name} COMMAND ${test_executable})
-- set_tests_properties(${test_name} PROPERTIES ENVIRONMENT "CHEMKIT_PLUGIN_PATH=${CMAKE_BINARY_DIR}/lib/chemkit/plugins/")
-+ set_tests_properties(${test_name} PROPERTIES ENVIRONMENT "CHEMKIT_PLUGIN_PATH=${CMAKE_BINARY_DIR}/lib${LIB_SUFFIX}/chemkit/plugins/")
- endmacro(add_chemkit_test)
-
- add_subdirectory(auto)
-diff --git a/tests/auto/bindings/python/CMakeLists.txt b/tests/auto/bindings/python/CMakeLists.txt
-index 9859867..70da693 100644
---- a/tests/auto/bindings/python/CMakeLists.txt
-+++ b/tests/auto/bindings/python/CMakeLists.txt
-@@ -5,7 +5,7 @@ endif()
- macro(add_chemkit_python_test test_name test_script)
- add_test(${test_name} ${PYTHON_EXECUTABLE} ${test_script})
- set_tests_properties(${test_name} PROPERTIES
-- ENVIRONMENT "PYTHONPATH=${CMAKE_BINARY_DIR}/bindings/python/;CHEMKIT_PLUGIN_PATH=${CMAKE_BINARY_DIR}/lib/chemkit/plugins")
-+ ENVIRONMENT "PYTHONPATH=${CMAKE_BINARY_DIR}/bindings/python/;CHEMKIT_PLUGIN_PATH=${CMAKE_BINARY_DIR}/lib${LIB_SUFFIX}/chemkit/plugins")
- endmacro(add_chemkit_python_test)
-
- add_chemkit_python_test(python.Atom ${CMAKE_CURRENT_SOURCE_DIR}/atomtest.py)
diff --git a/sci-libs/chemkit/files/chemkit-0.1-unbundle.patch b/sci-libs/chemkit/files/chemkit-0.1-unbundle.patch
deleted file mode 100644
index e8c9d18dca6e..000000000000
--- a/sci-libs/chemkit/files/chemkit-0.1-unbundle.patch
+++ /dev/null
@@ -1,191 +0,0 @@
- CMakeLists.txt | 21 +++++++++++++++++++++
- src/plugins/chemjson/CMakeLists.txt | 6 +++++-
- src/plugins/chemjson/chemjsonfileformat.cpp | 4 ++++
- src/plugins/cml/cmlfileformat.h | 4 ++++
- src/plugins/inchi/CMakeLists.txt | 4 +++-
- src/plugins/inchi/inchikeylineformat.cpp | 4 ++++
- src/plugins/inchi/inchilineformat.cpp | 4 ++++
- src/plugins/pdb/pdbmlfileformat.cpp | 4 ++++
- src/plugins/xtc/CMakeLists.txt | 9 +++++++--
- src/plugins/xtc/xtcfileformat.cpp | 4 ++++
- 10 files changed, 60 insertions(+), 4 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index e531be4..622ea9d 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -55,6 +55,27 @@ configure_file(
- # export the Chemkit package
- export(PACKAGE Chemkit)
-
-+option(USE_SYSTEM_INCHI "Use inchi installed in system" OFF)
-+option(USE_SYSTEM_JSONCPP "Use json cpp installed in system" OFF)
-+option(USE_SYSTEM_RAPIXML "Use rapidxml installed in system" OFF)
-+option(USE_SYSTEM_XDRF "Use xdrflib installed in system" OFF)
-+
-+if(USE_SYSTEM_INCHI)
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DSYSTEM_INCHI")
-+endif()
-+
-+if(USE_SYSTEM_JSONCPP)
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DSYSTEM_JSONCPP")
-+endif()
-+
-+if(USE_SYSTEM_RAPIDXML)
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DSYSTEM_RAPIDXML")
-+endif()
-+
-+if(USE_SYSTEM_XDRF)
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DSYSTEM_XDRF")
-+endif()
-+
- # build options
- option(CHEMKIT_WITH_GRAPHICS "Build the chemkit-graphics library." ON)
- option(CHEMKIT_WITH_IO "Build the chemkit-io library." ON)
-diff --git a/src/plugins/chemjson/CMakeLists.txt b/src/plugins/chemjson/CMakeLists.txt
-index 0e115b5..a5e6f48 100644
---- a/src/plugins/chemjson/CMakeLists.txt
-+++ b/src/plugins/chemjson/CMakeLists.txt
-@@ -10,7 +10,11 @@ set(SOURCES
- chemjsonplugin.cpp
- )
-
--aux_source_directory(../../3rdparty/jsoncpp/ JSONCPP_SOURCES)
-+if(NOT USE_SYSTEM_JSONCPP)
-+ aux_source_directory(../../3rdparty/jsoncpp/ JSONCPP_SOURCES)
-+else()
-+ target_link_libraries(chemjson jsoncpp)
-+endif()
-
- add_chemkit_plugin(chemjson ${SOURCES} ${JSONCPP_SOURCES})
- target_link_libraries(chemjson ${CHEMKIT_LIBRARIES})
-diff --git a/src/plugins/chemjson/chemjsonfileformat.cpp b/src/plugins/chemjson/chemjsonfileformat.cpp
-index a0d271e..3cd5827 100644
---- a/src/plugins/chemjson/chemjsonfileformat.cpp
-+++ b/src/plugins/chemjson/chemjsonfileformat.cpp
-@@ -43,7 +43,11 @@
- #include <chemkit/molecule.h>
- #include <chemkit/moleculefile.h>
-
-+#ifdef SYSTEM_JSONCPP
-+#include <jsoncpp/json/json.h>
-+#else
- #include "../../3rdparty/jsoncpp/json/json.h"
-+#endif
-
- namespace {
-
-diff --git a/src/plugins/cml/cmlfileformat.h b/src/plugins/cml/cmlfileformat.h
-index e813223..61a547d 100644
---- a/src/plugins/cml/cmlfileformat.h
-+++ b/src/plugins/cml/cmlfileformat.h
-@@ -38,7 +38,11 @@
-
- #include <chemkit/moleculefileformat.h>
-
-+#ifdef SYSTEM_RAPIDXML
-+#include <rapidxml/rapidxml.hpp>
-+#else
- #include "../../3rdparty/rapidxml/rapidxml.hpp"
-+#endif
-
- class CmlFileFormat : public chemkit::MoleculeFileFormat
- {
-diff --git a/src/plugins/inchi/CMakeLists.txt b/src/plugins/inchi/CMakeLists.txt
-index 2b25d9b..5f45f8a 100644
---- a/src/plugins/inchi/CMakeLists.txt
-+++ b/src/plugins/inchi/CMakeLists.txt
-@@ -7,7 +7,9 @@ set(SOURCES
- inchiplugin.cpp
- )
-
--aux_source_directory(../../3rdparty/inchi/ IUPAC_INCHI_SOURCES)
-+if(NOT USE_SYSTEM_INCHI)
-+ aux_source_directory(../../3rdparty/inchi/ IUPAC_INCHI_SOURCES)
-+endif()
-
- add_chemkit_plugin(inchi ${SOURCES} ${IUPAC_INCHI_SOURCES})
- target_link_libraries(inchi ${CHEMKIT_LIBRARIES})
-diff --git a/src/plugins/inchi/inchikeylineformat.cpp b/src/plugins/inchi/inchikeylineformat.cpp
-index 2682f95..cec0a17 100644
---- a/src/plugins/inchi/inchikeylineformat.cpp
-+++ b/src/plugins/inchi/inchikeylineformat.cpp
-@@ -38,7 +38,11 @@
- #include <boost/format.hpp>
-
- #include "inchilineformat.h"
-+#ifdef SYSTEM_INCHI
-+#include <inchi_api.h>
-+#else
- #include "../../3rdparty/inchi/inchi_api.h"
-+#endif
-
- InchiKeyLineFormat::InchiKeyLineFormat()
- : chemkit::LineFormat("inchikey")
-diff --git a/src/plugins/inchi/inchilineformat.cpp b/src/plugins/inchi/inchilineformat.cpp
-index 5b9bc42..ea5977c 100644
---- a/src/plugins/inchi/inchilineformat.cpp
-+++ b/src/plugins/inchi/inchilineformat.cpp
-@@ -42,7 +42,11 @@
-
- #include <boost/algorithm/string.hpp>
-
-+#ifdef SYSTEM_INCHI
-+#include <inchi_api.h>
-+#else
- #include "../../3rdparty/inchi/inchi_api.h"
-+#endif
-
- #include <chemkit/atom.h>
- #include <chemkit/bond.h>
-diff --git a/src/plugins/pdb/pdbmlfileformat.cpp b/src/plugins/pdb/pdbmlfileformat.cpp
-index 081a4ec..2ca4269 100644
---- a/src/plugins/pdb/pdbmlfileformat.cpp
-+++ b/src/plugins/pdb/pdbmlfileformat.cpp
-@@ -35,7 +35,11 @@
-
- #include "pdbmlfileformat.h"
-
-+#ifdef SYSTEM_RAPIDXML
-+#include <rapidxml/rapidxml.hpp>
-+#else
- #include "../../3rdparty/rapidxml/rapidxml.hpp"
-+#endif
-
- #include <chemkit/atom.h>
- #include <chemkit/polymer.h>
-diff --git a/src/plugins/xtc/CMakeLists.txt b/src/plugins/xtc/CMakeLists.txt
-index 98d8ba7..8c09e64 100644
---- a/src/plugins/xtc/CMakeLists.txt
-+++ b/src/plugins/xtc/CMakeLists.txt
-@@ -13,7 +13,12 @@ set(SOURCES
- xtcplugin.cpp
- )
-
--aux_source_directory(../../3rdparty/xdrf/ XDRF_SOURCES)
-+
-+if(USE_SYSTEM_XDRF)
-+ find_library(XDRF_LIBRARY NAMES xdrfile libxdrfile)
-+else()
-+ aux_source_directory(../../3rdparty/xdrf/ XDRF_SOURCES)
-+endif()
-
- add_chemkit_plugin(xtc ${SOURCES} ${XDRF_SOURCES})
--target_link_libraries(xtc ${CHEMKIT_LIBRARIES} ${Boost_LIBRARIES})
-+target_link_libraries(xtc ${CHEMKIT_LIBRARIES} ${Boost_LIBRARIES} ${XDRF_LIBRARY} )
-diff --git a/src/plugins/xtc/xtcfileformat.cpp b/src/plugins/xtc/xtcfileformat.cpp
-index 0f00cb6..f8659ca 100644
---- a/src/plugins/xtc/xtcfileformat.cpp
-+++ b/src/plugins/xtc/xtcfileformat.cpp
-@@ -47,7 +47,11 @@
- #include <chemkit/trajectoryframe.h>
- #include <chemkit/cartesiancoordinates.h>
-
-+#ifdef SYSTEM_XDRF
-+#include <xdrfile/xdrfile.h>
-+#else
- #include "../../3rdparty/xdrf/xdrf.h"
-+#endif
-
- XtcFileFormat::XtcFileFormat()
- : chemkit::TrajectoryFileFormat("xtc")