summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/cifparse-obj/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/cifparse-obj/files')
-rw-r--r--sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.3.patch87
-rw-r--r--sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.7.patch64
-rw-r--r--sci-libs/cifparse-obj/files/cifparse-obj-7.025-makefile.patch115
-rw-r--r--sci-libs/cifparse-obj/files/respect-flags-and-add-gcc4.patch302
4 files changed, 568 insertions, 0 deletions
diff --git a/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.3.patch b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.3.patch
new file mode 100644
index 000000000000..1715f493a6e0
--- /dev/null
+++ b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.3.patch
@@ -0,0 +1,87 @@
+diff -Naur cifparse-obj-v7.025-prod-src/cif-file-v1.0/src/CifFile.C cifparse-obj-v7.025-prod-src.new/cif-file-v1.0/src/CifFile.C
+--- cifparse-obj-v7.025-prod-src/cif-file-v1.0/src/CifFile.C 2008-02-06 07:17:50.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/cif-file-v1.0/src/CifFile.C 2008-09-03 09:36:41.000000000 -0400
+@@ -153,6 +153,7 @@
+ // VLAD - Carefully examine all methods that accept with, for cases where
+ // with is 0. This may happen if the value is empty !!
+
++#include <algorithm>
+ #include "GenString.h"
+ #include "CifString.h"
+ #include "regex.h"
+diff -Naur cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/FOtest3.C cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/FOtest3.C
+--- cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/FOtest3.C 2008-02-06 07:17:51.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/FOtest3.C 2008-09-03 09:40:12.000000000 -0400
+@@ -1,4 +1,5 @@
+ #include <iostream>
++#include <cstdlib>
+ #include "GenString.h"
+ #include "CifFile.h"
+
+diff -Naur cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/FOtest7.C cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/FOtest7.C
+--- cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/FOtest7.C 2008-02-06 07:17:51.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/FOtest7.C 2008-09-03 09:40:42.000000000 -0400
+@@ -3,6 +3,7 @@
+ */
+ #include "CifFile.h"
+ #include <iostream>
++#include <cstdlib>
+
+ void FillTestTable(ISTable *s);
+ void TwoCifFileObj();
+diff -Naur cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/FOtest8.C cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/FOtest8.C
+--- cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/FOtest8.C 2008-02-06 07:17:51.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/FOtest8.C 2008-09-03 09:41:06.000000000 -0400
+@@ -1,6 +1,7 @@
+ /* Test for reading binary files of two different versions*/
+ #include "CifFile.h"
+ #include <iostream>
++#include <cstdlib>
+
+
+ #define FALSE 0
+diff -Naur cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/SdbReader.C cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/SdbReader.C
+--- cifparse-obj-v7.025-prod-src/cifparse-test-v1.0/src/SdbReader.C 2008-02-06 07:17:51.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/cifparse-test-v1.0/src/SdbReader.C 2008-09-03 09:41:50.000000000 -0400
+@@ -1,4 +1,5 @@
+ #include <iostream>
++#include <cstdlib>
+ #include "CifFile.h"
+
+
+diff -Naur cifparse-obj-v7.025-prod-src/common-v4.5/src/GenString.C cifparse-obj-v7.025-prod-src.new/common-v4.5/src/GenString.C
+--- cifparse-obj-v7.025-prod-src/common-v4.5/src/GenString.C 2008-02-06 07:17:49.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/common-v4.5/src/GenString.C 2008-09-03 09:32:17.000000000 -0400
+@@ -138,7 +138,7 @@
+ POSSIBILITY THEREOF.
+ */
+
+-
++#include <cstring>
+ // Needed, since some platforms do not define std:: elsewhere
+ #include <ctype.h>
+
+diff -Naur cifparse-obj-v7.025-prod-src/tables-v8.0/src/ISTable.C cifparse-obj-v7.025-prod-src.new/tables-v8.0/src/ISTable.C
+--- cifparse-obj-v7.025-prod-src/tables-v8.0/src/ISTable.C 2008-02-06 07:17:50.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/tables-v8.0/src/ISTable.C 2008-09-03 09:35:57.000000000 -0400
+@@ -150,6 +150,8 @@
+ #include <sstream>
+ #include <iostream>
+ #include <iomanip>
++#include <algorithm>
++#include <climits>
+
+ #include "Exceptions.h"
+ #include "GenString.h"
+diff -Naur cifparse-obj-v7.025-prod-src/tables-v8.0/src/ITTable.C cifparse-obj-v7.025-prod-src.new/tables-v8.0/src/ITTable.C
+--- cifparse-obj-v7.025-prod-src/tables-v8.0/src/ITTable.C 2008-02-06 07:17:50.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/tables-v8.0/src/ITTable.C 2008-09-03 09:35:29.000000000 -0400
+@@ -150,6 +150,8 @@
+ #include <sstream>
+ #include <iostream>
+ #include <iomanip>
++#include <algorithm>
++#include <climits>
+
+ #include "Exceptions.h"
+ #include "GenString.h"
diff --git a/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.7.patch b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.7.patch
new file mode 100644
index 000000000000..b828ae618caa
--- /dev/null
+++ b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-gcc4.7.patch
@@ -0,0 +1,64 @@
+ common-v4.5/src/mapped_ptr_vector.C | 14 +++++++-------
+ 1 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/common-v4.5/src/mapped_ptr_vector.C b/common-v4.5/src/mapped_ptr_vector.C
+index 0ffff35..993d0b9 100644
+--- a/common-v4.5/src/mapped_ptr_vector.C
++++ b/common-v4.5/src/mapped_ptr_vector.C
+@@ -256,12 +256,12 @@ void mapped_ptr_vector<T, StringCompareT>::push_back(T* inP,
+ _vector.push_back(inP);
+
+ typename tIndex::value_type valuePair(inP->GetName(),
+- make_pair(_vector.size() - 1, fileIndex));
++ std::make_pair(_vector.size() - 1, fileIndex));
+
+ _index.insert(valuePair);
+
+ _currentName = inP->GetName();
+- _currentIndices = make_pair(_vector.size() - 1, fileIndex);
++ _currentIndices = std::make_pair(_vector.size() - 1, fileIndex);
+
+ }
+
+@@ -274,12 +274,12 @@ void mapped_ptr_vector<T, StringCompareT>::push_back(const string& name,
+ _vector.push_back(NULL);
+
+ typename tIndex::value_type valuePair(name,
+- make_pair(_vector.size() - 1, fileIndex));
++ std::make_pair(_vector.size() - 1, fileIndex));
+
+ _index.insert(valuePair);
+
+ _currentName = name;
+- _currentIndices = make_pair(_vector.size() - 1, fileIndex);
++ _currentIndices = std::make_pair(_vector.size() - 1, fileIndex);
+ }
+
+
+@@ -447,7 +447,7 @@ void mapped_ptr_vector<T, StringCompareT>::erase(const string& name)
+ if (is_equal(_currentName, name, keyComp))
+ {
+ _currentName.clear();
+- _currentIndices = make_pair(_vector.size(), (unsigned int)0);
++ _currentIndices = std::make_pair(_vector.size(), (unsigned int)0);
+ }
+
+ }
+@@ -532,7 +532,7 @@ pair<unsigned int, unsigned int> mapped_ptr_vector<T, StringCompareT>::get_indic
+ if (_vector.empty())
+ {
+ // Empty container. Return invalid index.
+- return(make_pair(_vector.size(), (unsigned int)0));
++ return(std::make_pair(_vector.size(), (unsigned int)0));
+ }
+
+ typename tIndex::key_compare keyComp = _index.key_comp();
+@@ -556,7 +556,7 @@ pair<unsigned int, unsigned int> mapped_ptr_vector<T, StringCompareT>::get_indic
+ else
+ {
+ // Not found. Return invalid index.
+- return(make_pair(_vector.size(), (unsigned int)0));
++ return(std::make_pair(_vector.size(), (unsigned int)0));
+ }
+ }
+
diff --git a/sci-libs/cifparse-obj/files/cifparse-obj-7.025-makefile.patch b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-makefile.patch
new file mode 100644
index 000000000000..9e9a61788ddf
--- /dev/null
+++ b/sci-libs/cifparse-obj/files/cifparse-obj-7.025-makefile.patch
@@ -0,0 +1,115 @@
+diff -Naur cifparse-obj-v7.025-prod-src/etc/make.platform.gnu3 cifparse-obj-v7.025-prod-src.new/etc/make.platform.gnu3
+--- cifparse-obj-v7.025-prod-src/etc/make.platform.gnu3 2008-02-06 07:17:49.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/etc/make.platform.gnu3 2008-09-03 09:18:55.000000000 -0400
+@@ -107,8 +107,8 @@
+ C_WARNINGS=$(WARNINGS)
+
+ # C compiler flags
+-CFLAGS=$(OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
+-CFLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
++CFLAGS=$(C_OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
++CFLAGS_NONANSI=$(C_OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+
+ ## C++ compiler
+@@ -128,13 +128,13 @@
+ EXT=C
+
+ # C++ compiler flags
+-C++FLAGS=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
++C++FLAGS=$(CXX_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+-C++FLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
++C++FLAGS_NONANSI=$(CXX_OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
+ $(DEFINES) $(INCLUDES)
+ # C++FLAGS_RELAXED should be set to avoid warnings reported by third party
+ # source code that is not maintained by PDB
+-C++FLAGS_RELAXED=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) $(DEFINES) \
++C++FLAGS_RELAXED=$(CXX_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) $(DEFINES) \
+ $(INCLUDES)
+
+ ## Fortran compiler
+@@ -144,7 +144,7 @@
+ F77=f77
+
+ # Fortran compiler flags
+-FFLAGS=-O -u
++FFLAGS=$(F_OPT)
+
+ # Additional Fortran libraries
+ F77LIBS=
+@@ -157,7 +157,7 @@
+ STATIC_LINKING=-static
+
+ # Linker flags
+-LDFLAGS=$(ABI) -w $(STATIC_LINKING)
++LDFLAGS=$(ABI) -w $(STATIC_LINKING) $(LD_OPT)
+ LDFLAGS_NO_STATIC=$(ABI) -w
+
+ # Fortran linker
+diff -Naur cifparse-obj-v7.025-prod-src/etc/make.platform.gnu4 cifparse-obj-v7.025-prod-src.new/etc/make.platform.gnu4
+--- cifparse-obj-v7.025-prod-src/etc/make.platform.gnu4 2008-02-06 07:17:49.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/etc/make.platform.gnu4 2008-09-03 09:20:16.000000000 -0400
+@@ -107,12 +107,12 @@
+ C_WARNINGS=$(WARNINGS)
+
+ # C compiler flags
+-CFLAGS=$(OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
+-CFLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
++CFLAGS=$(C_OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
++CFLAGS_NONANSI=$(C_OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+
+ ## C++ compiler
+-## This part defines C++ compiler information
++
+
+ # C++ compiler executable
+ CCC=g++
+@@ -128,13 +128,13 @@
+ EXT=C
+
+ # C++ compiler flags
+-C++FLAGS=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
++C++FLAGS=$(CXX_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+-C++FLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
++C++FLAGS_NONANSI=$(CXX_OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
+ $(DEFINES) $(INCLUDES)
+ # C++FLAGS_RELAXED should be set to avoid warnings reported by third party
+ # source code that is not maintained by PDB
+-C++FLAGS_RELAXED=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) $(DEFINES) \
++C++FLAGS_RELAXED=$(CXX_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) $(DEFINES) \
+ $(INCLUDES)
+
+ ## Fortran compiler
+@@ -144,7 +144,7 @@
+ F77=f77
+
+ # Fortran compiler flags
+-FFLAGS=-O -u
++FFLAGS=$(F_OPT)
+
+ # Additional Fortran libraries
+ F77LIBS=
+@@ -157,7 +157,7 @@
+ STATIC_LINKING=-static
+
+ # Linker flags
+-LDFLAGS=$(ABI) -w $(STATIC_LINKING)
++LDFLAGS=$(ABI) -w $(STATIC_LINKING) $(LD_OPT)
+ LDFLAGS_NO_STATIC=$(ABI) -w
+
+ # Fortran linker
+diff -Naur cifparse-obj-v7.025-prod-src/Makefile cifparse-obj-v7.025-prod-src.new/Makefile
+--- cifparse-obj-v7.025-prod-src/Makefile 2008-02-06 07:17:48.000000000 -0500
++++ cifparse-obj-v7.025-prod-src.new/Makefile 2008-09-03 09:19:12.000000000 -0400
+@@ -62,7 +62,7 @@
+ echo "------------------------------------------------------------"; \
+ echo "**** Making $$libdir ****"; \
+ echo "------------------------------------------------------------"; \
+- (cd $$libdir && $(MAKE) -f $(MAKEFILE) "OPT=-O" install) || exit 1; \
++ (cd $$libdir && $(MAKE) -f $(MAKEFILE) C_OPT="${CFLAGS}" CXX_OPT="${CXXFLAGS}" F_OPT="${FFLAGS}" LD_OPT="${LDFLAGS}" install) || exit 1; \
+ done
+
+ debug:
diff --git a/sci-libs/cifparse-obj/files/respect-flags-and-add-gcc4.patch b/sci-libs/cifparse-obj/files/respect-flags-and-add-gcc4.patch
new file mode 100644
index 000000000000..79d4914edf58
--- /dev/null
+++ b/sci-libs/cifparse-obj/files/respect-flags-and-add-gcc4.patch
@@ -0,0 +1,302 @@
+diff -urN -x make.log -x Makefile.platform cifparse-obj-v6.302-prod-src.orig/etc/make.platform.gnu3 cifparse-obj-v6.302-prod-src/etc/make.platform.gnu3
+--- cifparse-obj-v6.302-prod-src.orig/etc/make.platform.gnu3 2005-04-26 06:12:57.000000000 -0700
++++ cifparse-obj-v6.302-prod-src/etc/make.platform.gnu3 2005-12-18 22:50:21.000000000 -0800
+@@ -107,8 +107,8 @@
+ C_WARNINGS=$(WARNINGS)
+
+ # C compiler flags
+-CFLAGS=$(OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
+-CFLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
++CFLAGS=$(C_OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
++CFLAGS_NONANSI=$(C_OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+
+ ## C++ compiler
+@@ -125,12 +125,12 @@
+ # This variable specifies how to compile the C code. If it is set to C,
+ # that indicates that C code will be compiled with the C++ compiler.
+ # Otherwise it will be compiled with C compiler.
+-EXT=C
++EXT=c
+
+ # C++ compiler flags
+-C++FLAGS=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
++C++FLAGS=$(CCC_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+-C++FLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
++C++FLAGS_NONANSI=$(CCC_OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
+ $(DEFINES) $(INCLUDES)
+ # C++FLAGS_RELAXED should be set to avoid warnings reported by third party
+ # source code that is not maintained by PDB
+@@ -144,7 +144,7 @@
+ F77=f77
+
+ # Fortran compiler flags
+-FFLAGS=-O -u
++FFLAGS=$(F_OPT)
+
+ # Additional Fortran libraries
+ F77LIBS=
+diff -urN -x make.log -x Makefile.platform cifparse-obj-v6.302-prod-src.orig/etc/make.platform.gnu4 cifparse-obj-v6.302-prod-src/etc/make.platform.gnu4
+--- cifparse-obj-v6.302-prod-src.orig/etc/make.platform.gnu4 1969-12-31 16:00:00.000000000 -0800
++++ cifparse-obj-v6.302-prod-src/etc/make.platform.gnu4 2005-12-18 22:55:17.000000000 -0800
+@@ -0,0 +1,202 @@
++##########################################################################
++##
++## File: make.plaform.gnu4
++## Purpose: This file is a Linux platform makefile that supports GNU 4.x
++## compiler suite.
++##
++##########################################################################
++
++#-----Lexer and Parser section-------------------------------------------#
++
++# Lexer executable
++LEX=flex
++
++# Lexer flags
++LEXFLAGS=-Cfr -L
++
++# Parser executable
++YACC=bison
++
++# Parser flags
++YACCFLAGS=-d -v -l
++
++#------------------------------------------------------------------------#
++
++#-----Compilers section--------------------------------------------------#
++
++## ABI
++## This part defines an application binary interface to be used with the
++## compiler suite.
++ABI=
++
++## Warnings flags
++## This part defines warnings related flags
++
++# WARNINGS_AS_ERRORS defines flags to instruct all compilers to treat all
++# warnings as errors.
++
++# ALL_WARNINGS defines flags to instruct all compilers to report all
++# warnings.
++ALL_WARNINGS=-Wall
++
++# NO_DEPRECATED defines flags to instruct C++ compiler not to report
++# warnings about deprecated constructs still used in C++ code.
++NO_DEPRECATED=-Wno-deprecated
++
++# Collect all general warnings related flags
++WARNINGS=$(WARNINGS_AS_ERRORS) $(ALL_WARNINGS)
++
++## Platform specifics
++## This part defines platform specific information
++
++# Endianess.
++# Should be defined only for big endian platforms. Otherwise
++# it must be left undefined, which indicates little endian platform.
++#ENDIANESS=-DBIG_ENDIAN_PLATFORM
++
++# OS indicator. Should be defined only if SunOS is the platform
++#PLATFORM_OS=-DSUN_OS
++
++# Collect all platform related flags
++PLATFORM=$(ENDIANESS) $(PLATFORM_OS)
++
++## Compiler capabilities/restrictions related defines
++## This part defines variables based on the capabilities or restrictions
++## of the compiler suite used on the platform.
++
++# If STRCASECMP_OPTION is defined, that indicates that the compiler
++# suite/supporting libraries support strcasecmp() function.
++STRCASECMP_OPTION=-DHAVE_STRCASECMP
++
++# If INCL_TEMPLATE_SRC_OPTION is defined, that indicates that
++# compiler must include template method definition in template
++# header files in order to properly compile templates.
++INCL_TEMPLATE_SRC_OPTION=-DINCL_TEMPLATE_SRC
++
++# If PLACEMENT_NEW_OPTION is defined, that indicates that the compiler
++# suite/supporting libraries support placement new/delete operators.
++PLACEMENT_NEW_OPTION=-DHAVE_PLACEMENT_NEW
++
++# Collect all compiler capabilities/restrictions
++COMPILER=$(STRCASECMP_OPTION) $(INCL_TEMPLATE_SRC_OPTION) \
++ $(PLACEMENT_NEW_OPTION)
++
++# Collect all global defines
++GDEFINES=$(PLATFORM) $(COMPILER)
++
++# Collect all defines from global defines and defines specified in
++# module makefile
++DEFINES=$(GDEFINES) $(LDEFINES)
++
++## Global include directories
++GINCLUDES=
++
++# Collect all include directories from global include directories and
++# include directories specified in module makefile
++INCLUDES=$(LINCLUDES) $(GINCLUDES)
++
++## C compiler
++## This part defines C compiler information
++
++# C compiler executable
++CC=gcc
++
++# C compiler ANSI/NON-ANSI flags
++ANSI_C_FLAG=-ansi
++NON_ANSI_C_FLAG=
++C_WARNINGS=$(WARNINGS)
++
++# C compiler flags
++CFLAGS=$(C_OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
++CFLAGS_NONANSI=$(C_OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
++ $(INCLUDES)
++
++## C++ compiler
++## This part defines C++ compiler information
++
++# C++ compiler executable
++CCC=g++
++
++# C++ compiler ANSI/NON-ANSI flags
++ANSI_C_PLUS_FLAG=-ansi
++NON_ANSI_C_PLUS_FLAG=-traditional-cpp
++C_PLUS_WARNINGS=$(WARNINGS) $(NO_DEPRECATED)
++
++# This variable specifies how to compile the C code. If it is set to C,
++# that indicates that C code will be compiled with the C++ compiler.
++# Otherwise it will be compiled with C compiler.
++EXT=c
++
++# C++ compiler flags
++C++FLAGS=$(CCC_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
++ $(INCLUDES)
++C++FLAGS_NONANSI=$(CCC_OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
++ $(DEFINES) $(INCLUDES)
++# C++FLAGS_RELAXED should be set to avoid warnings reported by third party
++# source code that is not maintained by PDB
++C++FLAGS_RELAXED=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) $(DEFINES) \
++ $(INCLUDES)
++
++## Fortran compiler
++## This part defines Fortran compiler information
++
++# Fortran compiler executable
++F77=gfortran
++
++# Fortran compiler flags
++FFLAGS=$(F_OPT)
++
++# Additional Fortran libraries
++F77LIBS=
++
++#------------------------------------------------------------------------#
++
++#-----Linkers section----------------------------------------------------#
++
++# Static linking option. If not defined, dynamic linking is used.
++STATIC_LINKING=-static
++
++# Linker flags
++LDFLAGS=$(ABI) -w $(STATIC_LINKING)
++LDFLAGS_NO_STATIC=$(ABI) -w
++
++# Fortran linker
++F77_LINKER=gfortran
++
++#------------------------------------------------------------------------#
++
++#-----Archiver section---------------------------------------------------#
++
++# Archiver executable
++AR=ar
++
++# Archiver flags
++AR_GETFLAGS=xv
++AR_PUTFLAGS=rcvs
++
++#------------------------------------------------------------------------#
++
++#-----Ranlib-------------------------------------------------------------#
++
++RANLIB=true
++
++#------------------------------------------------------------------------#
++
++#-----Installer----------------------------------------------------------#
++
++INSTALL=../etc/cifinstall
++INSTALLOPTS=-m 0444
++
++#------------------------------------------------------------------------#
++
++#-----Stripper-----------------------------------------------------------#
++
++STRIP=strip
++
++#------------------------------------------------------------------------#
++
++#-----Shell--------------------------------------------------------------#
++
++SHELL=/bin/sh
++
++#------------------------------------------------------------------------#
+diff -urN -x make.log -x Makefile.platform cifparse-obj-v6.302-prod-src.orig/etc/platform.sh cifparse-obj-v6.302-prod-src/etc/platform.sh
+--- cifparse-obj-v6.302-prod-src.orig/etc/platform.sh 2005-04-26 06:12:57.000000000 -0700
++++ cifparse-obj-v6.302-prod-src/etc/platform.sh 2005-12-18 22:50:21.000000000 -0800
+@@ -47,23 +47,31 @@
+ ;;
+
+ Linux)
+-# Check if it is GCC version 3.x
+- gcc_ver=`gcc --version | grep -e " 3\."`
++# Check if it is GCC version 4.x
++ gcc_ver=`gcc --version | grep -e " 4\."`
+ if [[ -z $gcc_ver ]]
+ then
+-# It is not GCC version 3.x. Check if it is GCC version 2.x
+- gcc_ver=`gcc --version | grep -e "2\."`
++# It is not GCC version 4.x. Check if it is GCC version 3.x
++ gcc_ver=`gcc --version | grep -e " 3\."`
+ if [[ -z $gcc_ver ]]
+ then
+-# It is not GCC version 2.x either. Production can not be compiled.
+- sysid="unknown"
++# It is not GCC version 3.x. Check if it is GCC version 2.x
++ gcc_ver=`gcc --version | grep -e "2\."`
++ if [[ -z $gcc_ver ]]
++ then
++# It is not GCC version 2.x either. Production can not be compiled.
++ sysid="unknown"
++ else
++# It is GCC version 2.x
++ sysid="gnu2"
++ fi
+ else
+-# It is GCC version 2.x
+- sysid="gnu2"
++# It is GCC version 3.x
++ sysid="gnu3"
+ fi
+ else
+-# It is GCC version 3.x
+- sysid="gnu3"
++# It is GCC version 4.x
++ sysid="gnu4"
+ fi
+ ;;
+
+diff -urN -x make.log -x Makefile.platform cifparse-obj-v6.302-prod-src.orig/Makefile cifparse-obj-v6.302-prod-src/Makefile
+--- cifparse-obj-v6.302-prod-src.orig/Makefile 2005-04-26 06:12:57.000000000 -0700
++++ cifparse-obj-v6.302-prod-src/Makefile 2005-12-18 22:50:21.000000000 -0800
+@@ -54,7 +54,7 @@
+ echo "------------------------------------------------------------"; \
+ echo "**** Making $$libdir ****"; \
+ echo "------------------------------------------------------------"; \
+- (cd $$libdir && $(MAKE) -f $(MAKEFILE) "OPT=-O" install) || exit 1; \
++ (cd $$libdir && $(MAKE) -f $(MAKEFILE) C_OPT="${CFLAGS}" CCC_OPT="${CXXFLAGS}" F_OPT="${FFLAGS}" install) || exit 1; \
+ done
+
+ debug: