summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-12-29 13:57:25 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-29 13:57:25 +0100
commit184456970fa09df86d419c48020fdad2b5b3911a (patch)
tree90659e24224a8c5093bc7e101a09b370f580e812 /sci-libs/clblas/files/clblas-2.12-disable-multilib-cflags.patch
parentdev-libs/libstrophe: add new version 0.10.1 (diff)
downloadgentoo-184456970fa09df86d419c48020fdad2b5b3911a.tar.gz
gentoo-184456970fa09df86d419c48020fdad2b5b3911a.tar.bz2
gentoo-184456970fa09df86d419c48020fdad2b5b3911a.zip
sci-libs/clblas: Version bump to 2.12
Bug: https://bugs.gentoo.org/608086 Bug: https://bugs.gentoo.org/741386 Bug: https://bugs.gentoo.org/737410 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/clblas/files/clblas-2.12-disable-multilib-cflags.patch')
-rw-r--r--sci-libs/clblas/files/clblas-2.12-disable-multilib-cflags.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-libs/clblas/files/clblas-2.12-disable-multilib-cflags.patch b/sci-libs/clblas/files/clblas-2.12-disable-multilib-cflags.patch
new file mode 100644
index 000000000000..8e8f14871ef1
--- /dev/null
+++ b/sci-libs/clblas/files/clblas-2.12-disable-multilib-cflags.patch
@@ -0,0 +1,26 @@
+Description: disable multilib flags
+Author: Ghislain Antony Vaillant <ghisvail@gmail.com>
+Forwarded: not-needed
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -305,18 +305,6 @@
+ # Don't use -rpath.
+ set(CMAKE_SKIP_RPATH ON CACHE BOOL "Skip RPATH" FORCE)
+
+- # Need to determine the target machine of the C compiler, because
+- # the '-m32' and '-m64' flags are supported on x86 but not on e.g. ARM.
+- exec_program( "${CMAKE_C_COMPILER} -dumpmachine"
+- OUTPUT_VARIABLE CMAKE_C_COMPILER_MACHINE )
+- message( STATUS "CMAKE_C_COMPILER_MACHINE: ${CMAKE_C_COMPILER_MACHINE}" )
+- # The "86" regular expression matches x86, x86_64, i686, etc.
+- if(${CMAKE_C_COMPILER_MACHINE} MATCHES "86")
+- set(CMAKE_C_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_C_FLAGS}")
+- set(CMAKE_CXX_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_CXX_FLAGS}")
+- set(CMAKE_Fortran_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_Fortran_FLAGS}")
+- endif()
+-
+ if(TARGET_PLATFORM EQUAL 32)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fno-builtin")
+ endif()