summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-05-07 09:43:52 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-05-08 08:20:34 -0400
commit43f4976dbc20cb4c18668db393c05c71a66d9544 (patch)
treeee4b12612de560159199b0ec68438ca3db92922b /sci-libs/coinor-clp/coinor-clp-1.17.6.ebuild
parentsci-libs/coinor-clp: add an "<upstream>" tag to metadata.xml. (diff)
downloadgentoo-43f4976dbc20cb4c18668db393c05c71a66d9544.tar.gz
gentoo-43f4976dbc20cb4c18668db393c05c71a66d9544.tar.bz2
gentoo-43f4976dbc20cb4c18668db393c05c71a66d9544.zip
sci-libs/coinor-clp: new EAPI=7 version 1.17.6.
Another "standard" version bump that is getting less standard. I've added the usual coinor-* hacks and comments explaining them, but this package is worse than some of the others. The mumps and libscotch dependencies are being neglected in Gentoo, so a lot of that stuff is broken. To work around it, we now require sci-libs/mumps (and therefore sci-libs/scotch) to be built without USE=mpi. I don't feel great about this ebuild, but it's a necessary step towards a modern set of coinor-* packages that we can begin fixing in earnest. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/coinor-clp/coinor-clp-1.17.6.ebuild')
-rw-r--r--sci-libs/coinor-clp/coinor-clp-1.17.6.ebuild131
1 files changed, 131 insertions, 0 deletions
diff --git a/sci-libs/coinor-clp/coinor-clp-1.17.6.ebuild b/sci-libs/coinor-clp/coinor-clp-1.17.6.ebuild
new file mode 100644
index 000000000000..7449be2ae9f2
--- /dev/null
+++ b/sci-libs/coinor-clp/coinor-clp-1.17.6.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_PN=Clp
+
+DESCRIPTION="COIN-OR linear programming solver"
+HOMEPAGE="https://github.com/coin-or/Clp/"
+SRC_URI="https://github.com/coin-or/${MY_PN}/archive/releases/${PV}.tar.gz
+ -> ${P}.tar.gz"
+LICENSE="EPL-1.0"
+
+# major soname component
+SLOT="0/1"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples glpk metis mumps sparse static-libs test"
+RESTRICT="!test? ( test )"
+
+# Fortran is NOT needed, but the ./configure scripts for all of the CoinOR
+# packages contain a check for it. Gentoo bug 601648 and upstream issue,
+#
+# https://github.com/coin-or/CoinUtils/issues/132
+#
+BDEPEND="virtual/fortran
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+# USE=mpi is disabled on sci-libs/mumps because mumps/scotch are in
+# total disarray, but in particular for bugs 670759 and 695962. There
+# used to be some conditional USE=mpi stuff in src_prepare() that will
+# need to be put back if you restore the ability to build against
+# mumps[mpi].
+DEPEND="sci-libs/coinor-osi:=
+ sci-libs/coinor-utils:=
+ glpk? ( sci-mathematics/glpk:= sci-libs/amd )
+ metis? ( || ( sci-libs/metis sci-libs/parmetis ) )
+ mumps? ( sci-libs/mumps[-mpi] )
+ sparse? ( sci-libs/cholmod )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-releases-${PV}/${MY_PN}"
+
+src_prepare() {
+ # Needed to make the --with-coin-instdir in src_configure happy.
+ dodir /usr
+
+ # The file ClpCholeskyMumps.cpp does #include "mpi.h", and we
+ # need to point it to the right file. Our sci-libs/mumps ebuild
+ # is so ridiculous that I can't even tell if this is our fault
+ # or if it's something that should be reported upstream.
+ ln -s "${EPREFIX}"/usr/include/mpiseq/mpi.h src/mpi.h || die
+
+ # They don't need to guess at this, but they do, and get it wrong...
+ sed -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ -i configure \
+ || die "failed to fix the pkgconfig path in ${S}/configure"
+
+ default
+}
+
+src_configure() {
+ # The --enable-aboca flag is temporarily disabled, because the build
+ # is broken with it (see https://github.com/coin-or/Clp/issues/139).
+ # There's a fix, but I'm not going to bother with a patch for an
+ # an experimental feature.
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ $(use_with doc dot)
+ )
+ if use glpk; then
+ myeconfargs+=(
+ --with-amd-incdir="${EPREFIX}"/usr/include
+ --with-amd-lib=-lamd
+ --with-glpk-incdir="${EPREFIX}"/usr/include
+ --with-glpk-lib=-lglpk )
+ else
+ myeconfargs+=( --without-glpk )
+ fi
+ if use sparse; then
+ myeconfargs+=(
+ --with-amd-incdir="${EPREFIX}"/usr/include
+ --with-amd-lib=-lamd
+ --with-cholmod-incdir="${EPREFIX}"/usr/include
+ --with-cholmod-lib=-lcholmod )
+ else
+ myeconfargs+=( --without-amd --without-cholmod )
+ fi
+ if use metis; then
+ myeconfargs+=(
+ --with-metis-incdir="$($(tc-getPKG_CONFIG) --cflags metis | sed s/-I//)"
+ --with-metis-lib="$($(tc-getPKG_CONFIG) --libs metis)" )
+ else
+ myeconfargs+=( --without-metis )
+ fi
+ if use mumps; then
+ myeconfargs+=(
+ --with-mumps-incdir="${EPREFIX}"/usr/include
+ --with-mumps-lib="-lmumps_common -ldmumps -lzmumps -lsmumps -lcmumps -lmpiseq" )
+ else
+ myeconfargs+=( --without-mumps )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake all $(usex doc doxydoc "")
+}
+
+src_test() {
+ # NOT redundant! The build system has a "make check" target that does
+ # nothing, so if you don't specify "test" here, you'll get a no-op.
+ emake test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
+
+ emake DESTDIR="${D}" install
+
+ # Duplicate junk, and in the wrong location.
+ rm -r "${ED}/usr/share/coin/doc/${MY_PN}" || die
+
+ use examples && dodoc -r examples
+}