summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/coinor-flopcpp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/coinor-flopcpp')
-rw-r--r--sci-libs/coinor-flopcpp/Manifest1
-rw-r--r--sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild67
-rw-r--r--sci-libs/coinor-flopcpp/metadata.xml14
3 files changed, 82 insertions, 0 deletions
diff --git a/sci-libs/coinor-flopcpp/Manifest b/sci-libs/coinor-flopcpp/Manifest
new file mode 100644
index 000000000000..098180b5afc9
--- /dev/null
+++ b/sci-libs/coinor-flopcpp/Manifest
@@ -0,0 +1 @@
+DIST FlopC++-1.1.7.tgz 6631744 SHA256 c5bf2957f48d80638933a95dd1b2575b3b52a211313f664f9896b4c5050ff925 SHA512 40f59cb34f61f6ff1759a90909a81d724a562ee9dbfe91628ad8df1b8049afff254ceeb56f1e68a48d035e6d3a140744b8ebd8815ee39c9f01e17860c904942d WHIRLPOOL 4f2a5104e896980709f8b078c58771331516ed3753005768ec2faee6d6c6b9cedb2fc95cefd9e93c35dda7407094583543e032d0f0a0ca669062211b17ce9ef7
diff --git a/sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild b/sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild
new file mode 100644
index 000000000000..b80c6fefaadf
--- /dev/null
+++ b/sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=FlopC++
+
+DESCRIPTION="COIN-OR algebraic modeling language for linear optimization"
+HOMEPAGE="https://projects.coin-or.org/FlopC++/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs"
+
+RDEPEND="
+ sci-libs/coinor-cgl:=
+ sci-libs/coinor-clp:=
+ sci-libs/coinor-osi:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+S="${WORKDIR}/${MYPN}-${PV}/FlopCpp"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ $(use_with doc dot)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use doc; then
+ cd "${WORKDIR}/${MYPN}-${PV}/doxydoc" || die
+ doxygen doxygen.conf || die
+ fi
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${WORKDIR}/${MYPN}-${PV}/doxydoc/html/")
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-flopcpp/metadata.xml b/sci-libs/coinor-flopcpp/metadata.xml
new file mode 100644
index 000000000000..fd88f4003de5
--- /dev/null
+++ b/sci-libs/coinor-flopcpp/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The COIN-OR Formulation of Linear Optimization Problems in C++
+ (FLOPC++) is a linear optimization modelling language that can be
+ specified in a declarative style, similar to algebraic modelling
+ languages such as GAMS and AMPL, within a C++ program. As a result
+ the traditional strengths of algebraic modelling languages are
+ preserved, while embedding linear optimization models in software
+ applications is facilitated.
+</longdescription>
+</pkgmetadata>