summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-06 04:44:28 +0100
committerSam James <sam@gentoo.org>2022-08-06 04:49:29 +0100
commit34adbf714860fb2c1f167181de149ccd01e14efc (patch)
treec9ba3e16051b3281c2c453853ef53ff9adfaf855 /sci-libs/coinor-vol
parentdev-db/libodbc++: fix build w/ musl 1.2.3 (and possibly libcxx?) (diff)
downloadgentoo-34adbf714860fb2c1f167181de149ccd01e14efc.tar.gz
gentoo-34adbf714860fb2c1f167181de149ccd01e14efc.tar.bz2
gentoo-34adbf714860fb2c1f167181de149ccd01e14efc.zip
sci-libs/coinor-vol: fix build w/ musl 1.2.3
Closes: https://bugs.gentoo.org/841746 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/coinor-vol')
-rw-r--r--sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild6
-rw-r--r--sci-libs/coinor-vol/files/coinor-vol-1.5.4-musl-1.2.3-null.patch24
2 files changed, 29 insertions, 1 deletions
diff --git a/sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild b/sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild
index 53276b0f38c4..5ea2c976d627 100644
--- a/sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild
+++ b/sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -34,6 +34,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_PN}-releases-${PV}/${MY_PN}"
+PATCHES=(
+ "${FILESDIR}"/${P}-musl-1.2.3-null.patch
+)
+
src_prepare() {
# Needed to make the --with-coin-instdir in src_configure happy.
dodir /usr
diff --git a/sci-libs/coinor-vol/files/coinor-vol-1.5.4-musl-1.2.3-null.patch b/sci-libs/coinor-vol/files/coinor-vol-1.5.4-musl-1.2.3-null.patch
new file mode 100644
index 000000000000..96a154740ed4
--- /dev/null
+++ b/sci-libs/coinor-vol/files/coinor-vol-1.5.4-musl-1.2.3-null.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/841746
+https://github.com/coin-or/Vol/commit/7b65983cfbf66f9a615c1babcc28a7cd87eee3c4
+
+From: Stefan Vigerske <svigerske@gams.com>
+Date: Sat, 1 Feb 2020 17:45:41 +0000
+Subject: [PATCH] there should be no need to cast NULL, closes #1
+
+--- a/src/OsiVol/OsiVolSolverInterfaceIO.cpp
++++ b/src/OsiVol/OsiVolSolverInterfaceIO.cpp
+@@ -423,10 +423,10 @@ OsiVolSolverInterface::writeMps(const char *filename,
+ writer.setMpsData(*getMatrixByCol(), getInfinity(),
+ getColLower(), getColUpper(),
+ getObjCoefficients(),
+- reinterpret_cast<const char *> (NULL) /*integrality*/,
++ NULL /*integrality*/,
+ getRowLower(), getRowUpper(),
+- reinterpret_cast<const char **> (NULL) /*colnam*/,
+- reinterpret_cast<const char **> (NULL) /*rownam*/);
++ NULL /*colnam*/,
++ NULL /*rownam*/);
+ std::string fname = filename;
+ if (extension)
+ { if (extension[0] != '\0' && extension[0] != '.')
+