summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/colpack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/colpack')
-rw-r--r--sci-libs/colpack/Manifest3
-rw-r--r--sci-libs/colpack/colpack-1.0.6.ebuild41
-rw-r--r--sci-libs/colpack/colpack-1.0.8.ebuild45
-rw-r--r--sci-libs/colpack/colpack-1.0.9.ebuild44
-rw-r--r--sci-libs/colpack/files/colpack-1.0.6-flags.patch10
-rw-r--r--sci-libs/colpack/files/colpack-1.0.8-no-bin.patch15
-rw-r--r--sci-libs/colpack/files/colpack-1.0.9-fix_gcc49_omp.patch26
-rw-r--r--sci-libs/colpack/metadata.xml10
8 files changed, 194 insertions, 0 deletions
diff --git a/sci-libs/colpack/Manifest b/sci-libs/colpack/Manifest
new file mode 100644
index 000000000000..4319ec3a58ec
--- /dev/null
+++ b/sci-libs/colpack/Manifest
@@ -0,0 +1,3 @@
+DIST ColPack-1.0.6.tar.gz 1027189 SHA256 d03208883aaa48544124c7fa950c2ea1aa88bc38c7997c4a563b176b6bc212ea SHA512 646ffdd459c40906f6c57888c0e38b791f9559a88ce649e9041271655a9d98658db1c6c0f3b09d64b9bd2c7d74c71a6bd8b13972ae7c7bbac42b300b8e3844c9 WHIRLPOOL 80e5c7f368b362bf4dda84661b364fa1f55215446339fec98bce5dfd7a7dcffc97a79c73329d0a721f012c7bc6651626f6ed5b1f5e284c1b540bcf047d0178b7
+DIST ColPack-1.0.8.tar.gz 1213739 SHA256 4668e34318dc63c93dea9bc90938e1bfa738d0e323c909f89df388a4feddc41d SHA512 c059ab353ea229e73c9bc40cc4778db6852929b51d8d90f1e2c95fb66d0264622b3b6a54eecc1c9f4419d9f31578c83b7a62e4844e26ad23621d4e8c332bfff4 WHIRLPOOL dfc481b3fe79bcfbe796e5f40e52795ad1b7d2f15752dcc5972da93c865793ecd89bc87a4108736bf5b6db62d707d740a62b1c1f5f9321d92764616c804d1f9e
+DIST ColPack-1.0.9.tar.gz 1185335 SHA256 06c5d3e61ab873b27d7962a9f09e90cbc52ccd9f480e88f1ecb50e6bced11932 SHA512 762ab506f95788f9134033b60bf582472b80ab14766ad6795a7db1b780de0ae49bb30f1c9bd74b4f62cf46cc6029c37ef90a483e41b62bf4067cd4a71eb3db6c WHIRLPOOL f84e1766350265c3ecfb43d827327a018218be342f22adbd5f95d7172b9b489c12ed3978796b9c9d70b69058d88816ed6cb5979217ccca16c7691ecccedc3a51
diff --git a/sci-libs/colpack/colpack-1.0.6.ebuild b/sci-libs/colpack/colpack-1.0.6.ebuild
new file mode 100644
index 000000000000..7fb54e790d55
--- /dev/null
+++ b/sci-libs/colpack/colpack-1.0.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs autotools
+
+MYPN=ColPack
+
+DESCRIPTION="C++ algorithms for specialized vertex coloring problems"
+LICENSE="GPL-3 LGPL-3"
+HOMEPAGE="http://www.cscapes.org/coloringpage/software.htm"
+SRC_URI="http://www.cscapes.org/download/${MYPN}/${MYPN}-${PV}.tar.gz"
+
+SLOT="0"
+IUSE="openmp static-libs"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYPN}-${PV}"
+
+pkg_setup() {
+ if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
+ ewarn "You are using gcc without OpenMP"
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable openmp) \
+ $(use_enable static-libs static)
+}
diff --git a/sci-libs/colpack/colpack-1.0.8.ebuild b/sci-libs/colpack/colpack-1.0.8.ebuild
new file mode 100644
index 000000000000..25467aeafa4e
--- /dev/null
+++ b/sci-libs/colpack/colpack-1.0.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils toolchain-funcs autotools-utils
+
+MYPN=ColPack
+
+DESCRIPTION="C++ algorithms for specialized vertex coloring problems"
+LICENSE="GPL-3 LGPL-3"
+HOMEPAGE="http://www.cscapes.org/coloringpage/software.htm"
+SRC_URI="http://www.cscapes.org/download/${MYPN}/${MYPN}-${PV}.tar.gz"
+
+SLOT="0"
+IUSE="openmp static-libs"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYPN}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.6-flags.patch
+ "${FILESDIR}"/${PN}-1.0.8-no-bin.patch
+)
+
+pkg_setup() {
+ if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
+ ewarn "You are using gcc without OpenMP"
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable openmp)
+ )
+ autotools-utils_src_configure
+}
diff --git a/sci-libs/colpack/colpack-1.0.9.ebuild b/sci-libs/colpack/colpack-1.0.9.ebuild
new file mode 100644
index 000000000000..0b3d2d9ea88b
--- /dev/null
+++ b/sci-libs/colpack/colpack-1.0.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils toolchain-funcs autotools-utils
+
+MYPN=ColPack
+
+DESCRIPTION="C++ algorithms for specialized vertex coloring problems"
+LICENSE="GPL-3 LGPL-3"
+HOMEPAGE="http://www.cscapes.org/coloringpage/software.htm"
+SRC_URI="http://cscapes.cs.purdue.edu/download/${MYPN}/${MYPN}-${PV}.tar.gz"
+
+SLOT="0"
+IUSE="openmp static-libs"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYPN}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.6-flags.patch
+ "${FILESDIR}"/${PN}-1.0.8-no-bin.patch
+ "${FILESDIR}"/${P}-fix_gcc49_omp.patch
+)
+
+pkg_setup() {
+ if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
+ ewarn "You are using gcc without OpenMP"
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
+src_configure() {
+ local myeconfargs=( $(use_enable openmp) )
+ autotools-utils_src_configure
+}
diff --git a/sci-libs/colpack/files/colpack-1.0.6-flags.patch b/sci-libs/colpack/files/colpack-1.0.6-flags.patch
new file mode 100644
index 000000000000..6d4bb6a0d612
--- /dev/null
+++ b/sci-libs/colpack/files/colpack-1.0.6-flags.patch
@@ -0,0 +1,10 @@
+diff -Nur ColPack-1.0.6.orig/Makefile.am ColPack-1.0.6/Makefile.am
+--- ColPack-1.0.6.orig/Makefile.am 2012-04-13 03:25:37.000000000 +0100
++++ ColPack-1.0.6/Makefile.am 2012-04-13 03:30:35.000000000 +0100
+@@ -1,5 +1,5 @@
+ ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS}
+-COLPACK_COMMON_FLAGS = $(EXTRA_FLAGS) -O5
++COLPACK_COMMON_FLAGS = $(EXTRA_FLAGS)
+
+ INCLUDES = $(COLPACK_COMMON_FLAGS) \
+ -I$(top_srcdir)/Main \
diff --git a/sci-libs/colpack/files/colpack-1.0.8-no-bin.patch b/sci-libs/colpack/files/colpack-1.0.8-no-bin.patch
new file mode 100644
index 000000000000..f2400d66dd07
--- /dev/null
+++ b/sci-libs/colpack/files/colpack-1.0.8-no-bin.patch
@@ -0,0 +1,15 @@
+From: Sebastien Fabbro <bicatali@gentoo.org>
+Avoid installing the ColPack binary on an absolute path
+
+--- Makefile.am 2012-03-20 21:37:34.000000000 -0700
++++ Makefile.am 2012-09-17 14:24:02.168309078 -0700
+@@ -17,8 +17,7 @@
+ LDADD = libColPack.la
+ AM_DEFAULT_SOURCE_EXT = .cpp
+
+-noinst_bin_PROGRAMS = ColPack
+-noinst_bindir = $(abs_top_builddir)/progs
++noinst_PROGRAMS = ColPack
+ lib_LTLIBRARIES = libColPack.la
+ pkginclude_HEADERS = \
+ Utilities/CoutLock.h Utilities/command_line_parameter_processor.h \
diff --git a/sci-libs/colpack/files/colpack-1.0.9-fix_gcc49_omp.patch b/sci-libs/colpack/files/colpack-1.0.9-fix_gcc49_omp.patch
new file mode 100644
index 000000000000..0510be9f90ef
--- /dev/null
+++ b/sci-libs/colpack/files/colpack-1.0.9-fix_gcc49_omp.patch
@@ -0,0 +1,26 @@
+Index: ColPack-1.0.9/BipartiteGraphPartialColoring/BipartiteGraphPartialColoring.cpp
+===================================================================
+--- ColPack-1.0.9.orig/BipartiteGraphPartialColoring/BipartiteGraphPartialColoring.cpp
++++ ColPack-1.0.9/BipartiteGraphPartialColoring/BipartiteGraphPartialColoring.cpp
+@@ -388,8 +388,9 @@ namespace ColPack
+ if ( m_vi_LeftVertexColors [m_vi_Edges [x]] == m_vi_LeftVertexColors[v] && f(v) > f(m_vi_Edges [x]) ) {
+ //Algo 4 - Line 18: add [v] to R ; cont <- false; break
+ #pragma omp critical
++ {
+ vi_verticesNeedNewColor.push_back(v);
+-#pragma omp end critical
++ }
+ cont = false;
+ break;
+ }
+@@ -575,8 +576,9 @@ namespace ColPack
+ if ( m_vi_RightVertexColors [m_vi_Edges [x]] == m_vi_RightVertexColors[v] && f(v) > f(m_vi_Edges [x]) ) {
+ //Algo 4 - Line 18: add [v] to R ; cont <- false; break
+ #pragma omp critical
++ {
+ vi_verticesNeedNewColor.push_back(v);
+-#pragma omp end critical
++ }
+ cont = false;
+ break;
+ }
diff --git a/sci-libs/colpack/metadata.xml b/sci-libs/colpack/metadata.xml
new file mode 100644
index 000000000000..97c2ff62782c
--- /dev/null
+++ b/sci-libs/colpack/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ ColPack is a package comprising of implementations of algorithms for
+ the specialized vertex coloring problems as well as algorithms for a
+ variety of related supporting tasks in derivative computation.
+</longdescription>
+</pkgmetadata>