summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-15 15:41:21 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-15 16:03:52 +0200
commitb97ee0036c701fa502d36019420335b345345fa1 (patch)
tree77fb73b6e0111d12db204fe18e4526c27a23de85 /sci-libs/coot-data/coot-data-3.ebuild
parentsci-libs/mmdb: Drop unnecessary deps (diff)
downloadgentoo-b97ee0036c701fa502d36019420335b345345fa1.tar.gz
gentoo-b97ee0036c701fa502d36019420335b345345fa1.tar.bz2
gentoo-b97ee0036c701fa502d36019420335b345345fa1.zip
sci-libs/coot-data: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs/coot-data/coot-data-3.ebuild')
-rw-r--r--sci-libs/coot-data/coot-data-3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/coot-data/coot-data-3.ebuild b/sci-libs/coot-data/coot-data-3.ebuild
new file mode 100644
index 000000000000..b4c2d59cbea7
--- /dev/null
+++ b/sci-libs/coot-data/coot-data-3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Data for the Crystallographic Object-Oriented Toolkit"
+HOMEPAGE="http://www.biop.ox.ac.uk/coot/"
+SRC_URI="https://www2.mrc-lmb.cam.ac.uk/Personal/pemsley/coot/dependencies/reference-structures.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/coot
+ doins -r reference-structures
+
+ # Coot looks in the wrong spot for the monomer library
+ # Listens to ccp4's CCP4_LIB rather than CLIBD_MON
+ cat >> "${T}"/coot <<- EOF
+ COOT_REFMAC_LIB_DIR="${EPREFIX}/usr/share/"
+ COOT_REF_STRUCTS="${EPREFIX}/usr/share/coot/reference-structures/"
+ EOF
+
+ newenvd "${T}"/coot 20coot
+}