summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2021-07-15 05:32:49 -0500
committerMatthias Maier <tamiko@gentoo.org>2021-07-15 06:57:13 -0500
commit1ec4a90033b64d307051e251d5931f2de61c1c09 (patch)
tree536a558e3b5382d9e02634377e5dffeb35dcdf0c /sci-libs/dealii
parentmail-filter/bogofilter: removed wrong license (diff)
downloadgentoo-1ec4a90033b64d307051e251d5931f2de61c1c09.tar.gz
gentoo-1ec4a90033b64d307051e251d5931f2de61c1c09.tar.bz2
gentoo-1ec4a90033b64d307051e251d5931f2de61c1c09.zip
sci-libs/dealii: version bump to 9.3.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs/dealii')
-rw-r--r--sci-libs/dealii/Manifest2
-rw-r--r--sci-libs/dealii/dealii-9.3.1.ebuild161
2 files changed, 163 insertions, 0 deletions
diff --git a/sci-libs/dealii/Manifest b/sci-libs/dealii/Manifest
index 46301107d51a..9dc09aab7eef 100644
--- a/sci-libs/dealii/Manifest
+++ b/sci-libs/dealii/Manifest
@@ -2,3 +2,5 @@ DIST dealii-9.2.0-offline_documentation.tar.gz 277987911 BLAKE2B d14e15bc252f481
DIST dealii-9.2.0.tar.gz 24688964 BLAKE2B 60a8ede72a49cb2e658b3d6d53fb332a96f44a7fb9bb499ba54175138d49f38a9b75d9bea2eaddcaa3f50d97ce53961692b35f89578f535d32301680e6f1d68b SHA512 7c76435e45c9c302c4f95f588229f5a9b81f0450bd029729553c706a25dfd16f5c02c50fd2618d7e285d18927b63426110d2c6a074242b91cf789bd4bc77acc5
DIST dealii-9.3.0-offline_documentation.tar.gz 342390250 BLAKE2B 5ed1e5d5f7cd6a44f0dccc4b092c241fadc430facb77ec2a9ffb30d00dc13751f0ac08e2f05960584fbb60b26b64fa070c437f392e2e62b4ba1328e4efcd0677 SHA512 ff04cf3690160119041a9dc102ece81c351c41809fe1717cbc95aa97f2f1fe2ccc36e1b4b3045b73056a54fc7e3a27d3d734908760e9c34203b566b328b104b7
DIST dealii-9.3.0.tar.gz 24458373 BLAKE2B 27cdaee4e7ec9c170e11c5ba9bff8fd654bb2a9452df3402d5639268a6fe31565faa38d240810a0323b7253f2ed665c25fa0948c56b9924f1836531f2414bc92 SHA512 d558b5dda1067f7d995bc5f265614e3bc5e70190d24c1c61047af1ddc52fa007013c51901b9b8eacfbe8b360dffcb22aca87e0019ee09581b928e00c39198c98
+DIST dealii-9.3.1-offline_documentation.tar.gz 342389060 BLAKE2B 71b47816dd22f490168f91c667308ecf10d5733bb4e4d6f7f214dfa729f47e6f44bf32382167f2f6c864038d04c994cab7ef91ae647b4188c53995c5c2904bf3 SHA512 7ab70b7821924a4383f2d46bcb44e702858206a8444870d3e2282d726b2c1cf3009f615888206312aed34eae9595ff19664da422e33c47720cce5c5fd37c1e18
+DIST dealii-9.3.1.tar.gz 24459280 BLAKE2B c7f1d461017da24efd6f3247217fd1b889e0cbf2ac62c3fd305e03aed90d5ba82b58ceb84d34a84608b833b734e12abc77a63693aaa6eed767b4f5f157233ba0 SHA512 c3ba3e16fa4792bb4f3e85163e67b08271c84faff72c49b858a955851401adf2499e278790803061a61c4024964f6da3f0ef7b09c0370d8d0b5af16b7c3bdaef
diff --git a/sci-libs/dealii/dealii-9.3.1.ebuild b/sci-libs/dealii/dealii-9.3.1.ebuild
new file mode 100644
index 000000000000..0bdf1f25fbbb
--- /dev/null
+++ b/sci-libs/dealii/dealii-9.3.1.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake multilib
+
+# deal.II uses its own FindLAPACK.cmake file that calls into the system
+# FindLAPACK.cmake module and does additional internal setup. Do not remove
+# any of these modules:
+CMAKE_REMOVE_MODULES_LIST=""
+
+DESCRIPTION="Solving partial differential equations with the finite element method"
+HOMEPAGE="https://www.dealii.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dealii/dealii.git"
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz
+ doc? (
+ https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}-offline_documentation.tar.gz
+ )"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="
+ adolc assimp arpack cpu_flags_x86_avx cpu_flags_x86_avx512f
+ cpu_flags_x86_sse2 cuda +debug doc +examples ginkgo gmsh +gsl hdf5
+ +lapack metis mpi muparser opencascade p4est petsc
+ scalapack slepc +sparse static-libs sundials symengine trilinos
+"
+
+# TODO: add slepc use flag once slepc is packaged for gentoo-science
+REQUIRED_USE="
+ p4est? ( mpi )
+ slepc? ( petsc )
+ trilinos? ( mpi )"
+
+# FIXME: The opencascade-7.5.1 ebuild uses a new file system layout where
+# the names of the correct include and library directories are not easily
+# accessible. Just fix the version for the time being.
+CAS_VERSION=7.5.2
+
+RDEPEND="dev-libs/boost
+ app-arch/bzip2
+ sys-libs/zlib
+ dev-cpp/tbb
+ adolc? ( sci-libs/adolc )
+ arpack? ( sci-libs/arpack[mpi=] )
+ assimp? ( media-libs/assimp )
+ cuda? ( dev-util/nvidia-cuda-sdk )
+ ginkgo? ( sci-libs/ginkgo )
+ gmsh? ( sci-libs/gmsh )
+ gsl? ( sci-libs/gsl:= )
+ hdf5? ( sci-libs/hdf5[mpi=] )
+ lapack? ( virtual/lapack )
+ metis? ( >=sci-libs/parmetis-4 )
+ mpi? ( virtual/mpi )
+ muparser? ( dev-cpp/muParser )
+ opencascade? ( ~sci-libs/opencascade-${CAS_VERSION}:= )
+ p4est? ( sci-libs/p4est[mpi] )
+ petsc? ( sci-mathematics/petsc[mpi=] )
+ scalapack? ( sci-libs/scalapack )
+ slepc? ( sci-mathematics/slepc[mpi=] )
+ sparse? ( sci-libs/umfpack )
+ sundials? ( sci-libs/sundials:= )
+ symengine? ( >=sci-libs/symengine-0.4:= )
+ trilinos? ( sci-libs/trilinos )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] dev-lang/perl )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9.1.1-no-ld-flags.patch
+)
+
+src_configure() {
+ # deal.II needs a custom build type:
+ local CMAKE_BUILD_TYPE=$(usex debug DebugRelease Release)
+
+ local mycmakeargs=(
+ -DDEAL_II_PACKAGE_VERSION="${PV}"
+ -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=OFF
+ -DDEAL_II_ALLOW_AUTODETECTION=OFF
+ -DDEAL_II_ALLOW_PLATFORM_INTROSPECTION=OFF
+ -DDEAL_II_COMPILE_EXAMPLES=OFF
+ -DDEAL_II_DOCHTML_RELDIR="share/doc/${P}/html"
+ -DDEAL_II_DOCREADME_RELDIR="share/doc/${P}"
+ -DDEAL_II_COMPILE_EXAMPLES=OFF
+ -DDEAL_II_EXAMPLES_RELDIR="share/doc/${P}/examples"
+ -DDEAL_II_LIBRARY_RELDIR="$(get_libdir)"
+ -DDEAL_II_SHARE_RELDIR="share/${PN}"
+ -DDEAL_II_WITH_ZLIB=ON
+ -DDEAL_II_WITH_ADOLC="$(usex adolc)"
+ -DDEAL_II_WITH_ASSIMP="$(usex assimp)"
+ -DDEAL_II_WITH_ARPACK="$(usex arpack)"
+ -DDEAL_II_WITH_CUDA="$(usex cuda)"
+ -DDEAL_II_WITH_GINKGO="$(usex ginkgo)"
+ -DDEAL_II_COMPONENT_DOCUMENTATION="$(usex doc)"
+ -DDEAL_II_COMPONENT_EXAMPLES="$(usex examples)"
+ -DDEAL_II_WITH_GMSH="$(usex gmsh)"
+ -DDEAL_II_WITH_GSL="$(usex gsl)"
+ -DDEAL_II_WITH_HDF5="$(usex hdf5)"
+ -DDEAL_II_WITH_LAPACK="$(usex lapack)"
+ -DDEAL_II_WITH_METIS="$(usex metis)"
+ -DDEAL_II_WITH_MPI="$(usex mpi)"
+ -DDEAL_II_WITH_MUPARSER="$(usex muparser)"
+ -DDEAL_II_WITH_OPENCASCADE="$(usex opencascade)"
+ -DDEAL_II_WITH_P4EST="$(usex p4est)"
+ -DDEAL_II_WITH_PETSC="$(usex petsc)"
+ -DDEAL_II_WITH_SCALAPACK="$(usex scalapack)"
+ -DDEAL_II_WITH_SLEPC="$(usex slepc)"
+ -DDEAL_II_WITH_SUNDIALS="$(usex sundials)"
+ -DDEAL_II_WITH_SYMENGINE="$(usex symengine)"
+ -DDEAL_II_WITH_UMFPACK="$(usex sparse)"
+ -DBUILD_SHARED_LIBS="$(usex !static-libs)"
+ -DDEAL_II_PREFER_STATIC_LIBS="$(usex static-libs)"
+ -DDEAL_II_WITH_TBB=ON
+ -DDEAL_II_WITH_TRILINOS="$(usex trilinos)"
+ )
+
+ # Do a little dance for purely cosmetic "QA" reasons.
+ use opencascade && mycmakeargs+=(
+ -DOPENCASCADE_DIR="${CASROOT}/$(get_libdir)/opencascade-${CAS_VERSION}"
+ -DOPENCASCADE_INCLUDE_DIR="${CASROOT}/include/opencascade-${CAS_VERSION}"
+ )
+
+ # Do a little dance for purely cosmetic "QA" reasons. The build system
+ # does query for the highest instruction set first and skips the other
+ # variables if a "higher" variant is set
+ if use cpu_flags_x86_avx512f; then
+ mycmakeargs+=( -DDEAL_II_HAVE_AVX512=yes )
+ elif use cpu_flags_x86_avx; then
+ mycmakeargs+=( -DDEAL_II_HAVE_AVX=yes )
+ elif use cpu_flags_x86_avx; then
+ mycmakeargs+=( -DDEAL_II_HAVE_SSE2=yes )
+ fi
+
+ cmake_src_configure
+}
+
+src_install() {
+ if use doc && [[ ${PV} != *9999* ]]; then
+ # copy missing images to the build directory:
+ cp -r "${WORKDIR}"/doc/doxygen/deal.II/images \
+ "${BUILD_DIR}"/doc/doxygen/deal.II || die
+ # replace links:
+ sed -i \
+ 's#"http://www.dealii.org/images/steps/developer/\(step-.*\)"#"images/\1"#g' \
+ "${BUILD_DIR}"/doc/doxygen/deal.II/step_*.html || die "sed failed"
+ fi
+ cmake_src_install
+
+ # decompress the installed example sources:
+ use examples && docompress -x /usr/share/doc/${PF}/examples
+}