summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2022-02-17 01:13:25 +0300
committerSam James <sam@gentoo.org>2022-02-18 03:05:53 +0000
commit01f352b1649fc560c6cea09b91e72e56b49f6f68 (patch)
treeac42f92f06414026c30cd7a989d9754847ff9464 /sci-libs/flann/flann-1.9.1-r5.ebuild
parentsci-libs/flann: revbump to fix MATLAB support (diff)
downloadgentoo-01f352b1649fc560c6cea09b91e72e56b49f6f68.tar.gz
gentoo-01f352b1649fc560c6cea09b91e72e56b49f6f68.tar.bz2
gentoo-01f352b1649fc560c6cea09b91e72e56b49f6f68.zip
sci-libs/flann: fix RUNPATH with MPI
Bug: https://bugs.gentoo.org/795828 Signed-off-by: Alexander Golubev <fatzer2@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24221 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/flann/flann-1.9.1-r5.ebuild')
-rw-r--r--sci-libs/flann/flann-1.9.1-r5.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/sci-libs/flann/flann-1.9.1-r5.ebuild b/sci-libs/flann/flann-1.9.1-r5.ebuild
index 716c7a4fec72..788c2733be10 100644
--- a/sci-libs/flann/flann-1.9.1-r5.ebuild
+++ b/sci-libs/flann/flann-1.9.1-r5.ebuild
@@ -17,6 +17,7 @@ IUSE="cuda doc examples mpi octave openmp"
BDEPEND="
app-arch/unzip
doc? ( dev-tex/latex2html )
+ mpi? ( app-admin/chrpath )
"
DEPEND="
app-arch/lz4:=
@@ -85,4 +86,9 @@ src_configure() {
src_install() {
cmake_src_install
find "${D}" -name 'lib*.a' -delete || die
+
+ # bug 795828; mpicc volunterely adds some runpaths
+ if use mpi; then
+ chrpath -d "${ED}"/usr/bin/flann_mpi_{client,server} || die
+ fi
}