summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/flann/flann-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/flann/flann-9999.ebuild')
-rw-r--r--sci-libs/flann/flann-9999.ebuild111
1 files changed, 111 insertions, 0 deletions
diff --git a/sci-libs/flann/flann-9999.ebuild b/sci-libs/flann/flann-9999.ebuild
new file mode 100644
index 000000000000..ebc34bb597bd
--- /dev/null
+++ b/sci-libs/flann/flann-9999.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils cuda eutils git-r3 multilib toolchain-funcs
+
+DESCRIPTION="Library for performing fast approximate nearest neighbor searches in high dimensional spaces"
+HOMEPAGE="http://www.cs.ubc.ca/research/flann/"
+SRC_URI="test? ( http://dev.gentoo.org/~bicatali/distfiles/${PN}-1.8.4-testdata.tar.xz )"
+EGIT_REPO_URI="https://github.com/mariusmuja/flann.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="cuda doc examples mpi openmp octave static-libs test"
+
+RDEPEND="
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-5.5 )
+ mpi? (
+ sci-libs/hdf5[mpi]
+ dev-libs/boost[mpi]
+ )
+ !mpi? ( !sci-libs/hdf5[mpi] )
+ octave? ( >=sci-mathematics/octave-3.6.4-r1 )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ doc? ( dev-tex/latex2html )
+ test? (
+ dev-cpp/gtest
+ cuda? ( sci-libs/hdf5 )
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.4-options.patch
+ "${FILESDIR}"/${PN}-1.8.4-CUDA_NVCC_FLAGS.patch
+ "${FILESDIR}"/${PN}-1.8.4-cuda5.5.patch
+ "${FILESDIR}"/${PN}-1.8.4-multilib.patch
+ "${FILESDIR}"/${PN}-1.8.4-docdir.patch
+)
+
+pkg_setup() {
+ if use openmp; then
+ if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp ; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+ fi
+}
+
+src_unpack() {
+ default
+ git-r3_src_unpack
+}
+
+src_prepare() {
+ # bug #302621
+ use mpi && export CXX=mpicxx
+
+ # produce pure octave files
+ # octave gentoo installation for .m files respected
+ sed -i \
+ -e 's/--mex//' \
+ -e 's/\.mex/\.oct/' \
+ -e '/FILES/s/${MEX_FILE}//' \
+ -e 's:share/flann/octave:share/octave/site/m:' \
+ -e "/CUSTOM_TARGET/a\INSTALL(FILES \${MEX_FILE} DESTINATION libexec/octave/site/oct/${CHOST})" \
+ src/matlab/CMakeLists.txt || die
+ use cuda && cuda_src_prepare
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ # python bindings are split
+ local mycmakeargs=(
+ -DBUILD_C_BINDINGS=ON
+ -DBUILD_PYTHON_BINDINGS=OFF
+ -DPYTHON_EXECUTABLE=
+ -DDOCDIR=share/doc/${PF}
+ $(cmake-utils_use_build cuda CUDA_LIB)
+ $(cmake-utils_use_build examples)
+ $(cmake-utils_use_build doc)
+ $(cmake-utils_use_build test TESTS)
+ $(cmake-utils_use_build octave MATLAB_BINDINGS)
+ $(cmake-utils_use_use mpi)
+ $(cmake-utils_use_use openmp)
+ )
+ use cuda && \
+ mycmakeargs+=(
+ -DCUDA_NVCC_FLAGS="${NVCCFLAGS},-arsch"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ ln -s "${WORKDIR}"/testdata/* test/ || die
+ # -j1 to avoid obversubscribing jobs
+ LD_LIBRARY_PATH="${BUILD_DIR}/lib" \
+ cmake-utils_src_compile -j1 test
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README.md
+ if ! use static-libs; then
+ find "${ED}" -name 'lib*.a' -exec rm -rf '{}' '+' || die
+ fi
+}