summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-09 20:38:45 +0000
committerSam James <sam@gentoo.org>2021-03-09 20:43:26 +0000
commita2df5bcead58163828cde20535e4b4f4204f4ecf (patch)
tree123df63ca2d5df2783a2e2a018a2653ccf0e76f7 /sci-libs/gdal/gdal-3.2.1-r1.ebuild
parentapp-crypt/aespipe: stable 2.4f for sparc, bug #775098 (diff)
downloadgentoo-a2df5bcead58163828cde20535e4b4f4204f4ecf.tar.gz
gentoo-a2df5bcead58163828cde20535e4b4f4204f4ecf.tar.bz2
gentoo-a2df5bcead58163828cde20535e4b4f4204f4ecf.zip
sci-libs/gdal: respect libdir
To be upstreamed. Unfortunately, we can't do *everything* required in Gentoo in the patch, as there's a --with-local argument which I'd prefer to get rid of, but is a bit too invasive of a change for me to want to push upstream for now. So, we settle on a single sed in the ebuild, which is an improvement! Closes: https://bugs.gentoo.org/696106 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/gdal/gdal-3.2.1-r1.ebuild')
-rw-r--r--sci-libs/gdal/gdal-3.2.1-r1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sci-libs/gdal/gdal-3.2.1-r1.ebuild b/sci-libs/gdal/gdal-3.2.1-r1.ebuild
index 5eb32d7fbfb8..ebac034babcf 100644
--- a/sci-libs/gdal/gdal-3.2.1-r1.ebuild
+++ b/sci-libs/gdal/gdal-3.2.1-r1.ebuild
@@ -88,11 +88,18 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-2.2.3-soname.patch"
"${FILESDIR}/${PN}-2.3.0-curl.patch" # bug 659840
+ "${FILESDIR}/${PN}-3.2.1-libdir.patch"
)
src_prepare() {
default
+ # Drop a --prefix hack in the upstream build system
+ # We don't want the line at all, so let's just drop it rather than
+ # trying to put in the right libdir value.
+ sed -e '/\$ADD_PREFIX\/lib/d' \
+ -i configure.ac || die
+
sed -e "s: /usr/: \"${EPREFIX}\"/usr/:g" \
-i configure.ac || die
@@ -131,10 +138,10 @@ src_configure() {
--with-geotiff
--with-gnm
--with-hide-internal-symbols
- --with-libjson-c="${EPREFIX}"/usr/
+ --with-libjson-c="${EPREFIX}"/usr
--with-libtiff
--with-libtool
- --with-libz="${EPREFIX}"/usr/
+ --with-libz="${EPREFIX}"/usr
--without-charls
--without-dods-root
--without-ecw