summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/getdata/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/getdata/files')
-rw-r--r--sci-libs/getdata/files/getdata-0.8.5-out-of-source.patch16
-rw-r--r--sci-libs/getdata/files/getdata-0.8.5-serial-test.patch42
2 files changed, 58 insertions, 0 deletions
diff --git a/sci-libs/getdata/files/getdata-0.8.5-out-of-source.patch b/sci-libs/getdata/files/getdata-0.8.5-out-of-source.patch
new file mode 100644
index 000000000000..45a6c7e14c31
--- /dev/null
+++ b/sci-libs/getdata/files/getdata-0.8.5-out-of-source.patch
@@ -0,0 +1,16 @@
+ bindings/python/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/bindings/python/Makefile.am b/bindings/python/Makefile.am
+index c2ab221..f5ade68 100644
+--- a/bindings/python/Makefile.am
++++ b/bindings/python/Makefile.am
+@@ -35,7 +35,7 @@ LIBS=
+
+ BUILT_SOURCES = pyconstants.c
+ AM_CFLAGS = ${WALL} -fno-strict-aliasing
+-AM_CPPFLAGS = $(CPPFLAGS) $(PYTHON_CPPFLAGS) $(NUMPY_CPPFLAGS)
++AM_CPPFLAGS = $(CPPFLAGS) $(PYTHON_CPPFLAGS) $(NUMPY_CPPFLAGS) -I$(top_srcdir)/src
+ pygetdata_la_LDFLAGS = -module -avoid-version \
+ -export-symbols-regex initpygetdata
+ pygetdata_la_LIBADD = $(PYTHON_LIBS) ../../src/libgetdata.la
diff --git a/sci-libs/getdata/files/getdata-0.8.5-serial-test.patch b/sci-libs/getdata/files/getdata-0.8.5-serial-test.patch
new file mode 100644
index 000000000000..976757ea8646
--- /dev/null
+++ b/sci-libs/getdata/files/getdata-0.8.5-serial-test.patch
@@ -0,0 +1,42 @@
+ bindings/Makefile.am | 6 +-----
+ bindings/python/test/Makefile.am | 3 +--
+ 2 files changed, 2 insertions(+), 7 deletions(-)
+
+diff --git a/bindings/Makefile.am b/bindings/Makefile.am
+index df53b0f..ec33316 100644
+--- a/bindings/Makefile.am
++++ b/bindings/Makefile.am
+@@ -38,10 +38,6 @@ if MAKE_MATLABBINDINGS
+ MATLAB_SUBDIR=matlab
+ endif
+
+-if MAKE_PYBINDINGS
+-PY_SUBDIR=python
+-endif
+-
+ if MAKE_PERLBINDINGS
+ PERL_SUBDIR=perl
+ endif
+@@ -52,7 +48,7 @@ make_parameters_SOURCES = make_parameters.c
+ nodist_make_parameters_SOURCES = ../src/getdata.h ../src/gd_config.h
+
+ SUBDIRS = . ${F77_SUBDIR} ${CXX_SUBDIR} ${IDL_SUBDIR} ${MATLAB_SUBDIR} \
+- ${PY_SUBDIR} ${PERL_SUBDIR}
++ ${PERL_SUBDIR}
+
+ make_parameters$(EXEEXT): $(make_parameters_SOURCES) \
+ $(nodist_make_parameters_SOURCES)
+diff --git a/bindings/python/test/Makefile.am b/bindings/python/test/Makefile.am
+index d159cad..b793b02 100644
+--- a/bindings/python/test/Makefile.am
++++ b/bindings/python/test/Makefile.am
+@@ -18,8 +18,7 @@
+ # along with GetData; if not, write to the Free Software Foundation, Inc.,
+ # 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ #
+-AUTOMAKE_OPTIONS = foreign
+-
++AUTOMAKE_OPTIONS = foreign serial-tests
+ if TEST_PYTHON
+ TESTS_ENVIRONMENT=${DL_LIBRARY_PATH}=${${DL_LIBRARY_PATH}}:../../../src/.libs PYTHONPATH=../.libs/ ${PYTHON}
+ pyTESTS=callback.py big_test.py