summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-03-16 22:42:55 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-03-18 20:10:11 +0000
commitc9a62f92fd53c520cff4ca6607e707a11e2e761e (patch)
tree910fdd36a4fc17e7c9a903683b859246e2506493 /sci-libs/hdf/hdf-4.2.11.ebuild
parentsci-visualization/opendx: switch to virtual/szip (diff)
downloadgentoo-c9a62f92fd53c520cff4ca6607e707a11e2e761e.tar.gz
gentoo-c9a62f92fd53c520cff4ca6607e707a11e2e761e.tar.bz2
gentoo-c9a62f92fd53c520cff4ca6607e707a11e2e761e.zip
sci-libs/hdf: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-libs/hdf/hdf-4.2.11.ebuild')
-rw-r--r--sci-libs/hdf/hdf-4.2.11.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/sci-libs/hdf/hdf-4.2.11.ebuild b/sci-libs/hdf/hdf-4.2.11.ebuild
new file mode 100644
index 000000000000..d12e40d9b695
--- /dev/null
+++ b/sci-libs/hdf/hdf-4.2.11.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+FORTRAN_NEEDED=fortran
+
+inherit fortran-2 toolchain-funcs autotools flag-o-matic
+
+MYP=${P/_p/-patch}
+
+DESCRIPTION="General purpose library and format for storing scientific data"
+HOMEPAGE="http://www.hdfgroup.org/hdf4.html"
+SRC_URI="http://www.hdfgroup.org/ftp/HDF/HDF_Current/src/${MYP}.tar.bz2"
+
+SLOT="0"
+LICENSE="NCSA-HDF"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples fortran szip static-libs test"
+REQUIRED_USE="test? ( szip )"
+
+RDEPEND="
+ sys-libs/zlib
+ virtual/jpeg:0
+ szip? ( virtual/szip )"
+DEPEND="${RDEPEND}
+ test? ( virtual/szip )"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2.11-fix-szip-detection.patch
+ "${FILESDIR}"/${PN}-4.2.11-enable-fortran-shared.patch
+ "${FILESDIR}"/${PN}-4.2.11-fix-examples-dir.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e 's/-R/-L/g' config/commence.am || die #rpath
+ eautoreconf
+ [[ $(tc-getFC) = *gfortran ]] && append-fflags -fno-range-check
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --enable-production=gentoo \
+ --disable-netcdf \
+ $(use_enable fortran) \
+ $(use_enable static-libs static) \
+ $(use_with szip szlib) \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files --all
+ dodoc release_notes/{RELEASE,HISTORY,bugs_fixed,misc_docs}.txt
+ cd "${ED}"usr
+ use examples || rm -rf share/doc/${PF}/examples
+ mv bin/ncgen{,-hdf} || die
+ mv bin/ncdump{,-hdf} || die
+ mv share/man/man1/ncgen{,-hdf}.1 || die
+ mv share/man/man1/ncdump{,-hdf}.1 || die
+}