summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2022-06-11 03:41:28 -0500
committerMatthias Maier <tamiko@gentoo.org>2022-06-11 03:44:35 -0500
commitbf577f5e59ea4270d52770db803cc3648bda50af (patch)
tree13e957b5c47cda5c992b447d5920af43eca07eda /sci-libs/hypre
parentsci-libs/trilinos: fix underlinkage by disabling zadelus as well (diff)
downloadgentoo-bf577f5e59ea4270d52770db803cc3648bda50af.tar.gz
gentoo-bf577f5e59ea4270d52770db803cc3648bda50af.tar.bz2
gentoo-bf577f5e59ea4270d52770db803cc3648bda50af.zip
sci-libs/hypre: add 2.24.0
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs/hypre')
-rw-r--r--sci-libs/hypre/Manifest1
-rw-r--r--sci-libs/hypre/hypre-2.24.0.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/sci-libs/hypre/Manifest b/sci-libs/hypre/Manifest
index 98ad73cf0d12..201bed67a1f1 100644
--- a/sci-libs/hypre/Manifest
+++ b/sci-libs/hypre/Manifest
@@ -1,2 +1,3 @@
DIST hypre-2.20.0.tar.gz 5971556 BLAKE2B 63cef33913f1f4c569c396dd18227ae4346807e659306521e9340789944e22dc70be3b9baec7fb1385f562b53045e5c87fcad604aa242a941199ff9fe0a0c21d SHA512 842868b494960506fa3df4e72abb42084d701ec14305f9b040b9dcb578b4bbdaa8afb079057a7e53ad721b440c72ee804775c3b8319f2d01a2f281920a9cd350
DIST hypre-2.21.0.tar.gz 6017038 BLAKE2B 500885cbd9f2b79c8740d1031a3dd9e5fd141dccfe2101ceed555cb7cbef77989b6af2c80f9b08e8efd6e2401269415532614d40512f93371397389e0fb15595 SHA512 20f860b0c25190608b50d577e03ab241d8caa1dbf7a7e56484e984710a586b1f4b63c72135488a756f42aa6a58d0a26b0c4e6e1680c3f7faabdf68e2559293b0
+DIST hypre-2.24.0.tar.gz 6116863 BLAKE2B fade61df0dcef3a93c8f4ff32eb72adbef56d572b8ef18202d8cdbbbd4c53a46a21f3478cf10720c64b1eaf0731e5a6f2236736ec9631f8500ce966f55d03cfe SHA512 4f27e99ba2923c6394ccc3705930897430becef840415004d6fae2fa311fef5b2399265ec1211364f883b35d00933523e65888419890902bcd4e1e6942b66560
diff --git a/sci-libs/hypre/hypre-2.24.0.ebuild b/sci-libs/hypre/hypre-2.24.0.ebuild
new file mode 100644
index 000000000000..8c9d5ab220f1
--- /dev/null
+++ b/sci-libs/hypre/hypre-2.24.0.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+FORTRAN_NEEDED=fortran
+
+inherit fortran-2 toolchain-funcs flag-o-matic
+
+DESCRIPTION="Parallel matrix preconditioners library"
+HOMEPAGE="https://computation.llnl.gov/projects/hypre-scalable-linear-solvers-multigrid-methods"
+SRC_URI="https://github.com/hypre-space/hypre/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug examples fortran int64 openmp mpi"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ sci-libs/superlu:=
+ virtual/blas
+ virtual/lapack
+ mpi? ( virtual/mpi )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG COPYRIGHT README )
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # link with system superlu and propagate LDFLAGS
+ sed -e "s:@LIBS@:@LIBS@ $($(tc-getPKG_CONFIG) --libs superlu):" \
+ -e 's:_SHARED@:_SHARED@ $(LDFLAGS):g' \
+ -i src/config/Makefile.config.in || die
+
+ sed -e '/HYPRE_ARCH/s: = :=:g' \
+ -i src/configure || die
+
+ # link with system blas and lapack
+ sed -e '/^BLASFILES/d' \
+ -e '/^LAPACKFILES/d' \
+ -i src/lib/Makefile || die
+}
+
+src_configure() {
+ tc-export CC CXX
+ append-flags -Dhypre_dgesvd=dgesvd_
+
+ if use openmp ; then
+ append-flags -fopenmp
+ append-ldflags -fopenmp
+ fi
+
+ if use mpi ; then
+ CC=mpicc
+ FC=mpif77
+ CXX=mpicxx
+ fi
+
+ cd src || die
+
+ # without-superlu: means do not use bundled one
+ econf \
+ --enable-shared \
+ --with-blas-libs="$($(tc-getPKG_CONFIG) --libs-only-l blas | sed -e 's/-l//g')" \
+ --with-blas-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L blas | sed -e 's/-L//g')" \
+ --with-lapack-libs="$($(tc-getPKG_CONFIG) --libs-only-l lapack | sed -e 's/-l//g')" \
+ --with-lapack-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L lapack | sed -e 's/-L//g')" \
+ --with-timing \
+ --without-superlu \
+ $(use_enable debug) \
+ $(use_enable openmp hopscotch) \
+ $(use_enable int64 bigint) \
+ $(use_enable fortran) \
+ $(use_with openmp) \
+ $(use_with mpi MPI)
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/src/lib:${LD_LIBRARY_PATH}" \
+ PATH="${S}/src/test:${PATH}" \
+ emake -C src check
+}
+
+src_install() {
+ emake -C src install \
+ HYPRE_INSTALL_DIR="${ED}" \
+ HYPRE_LIB_INSTALL="${ED}/usr/$(get_libdir)" \
+ HYPRE_INC_INSTALL="${ED}/usr/include/hypre"
+
+ if use examples; then
+ dodoc -r src/examples
+ fi
+}