summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-02-18 00:06:09 +0800
committerJason Zaman <perfinion@gentoo.org>2019-02-18 20:52:02 +0800
commitab97a3cdf534982025e78c19559cf2540c5ea6a8 (patch)
treeeb2f4c0257772a6df42e16544a2d7650dd6cff2d /sci-libs/keras-applications/keras-applications-1.0.7.ebuild
parentsci-libs/keras-preprocessing: bump 1.0.9 (diff)
downloadgentoo-ab97a3cdf534982025e78c19559cf2540c5ea6a8.tar.gz
gentoo-ab97a3cdf534982025e78c19559cf2540c5ea6a8.tar.bz2
gentoo-ab97a3cdf534982025e78c19559cf2540c5ea6a8.zip
sci-libs/keras-applications: bump 1.0.7
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sci-libs/keras-applications/keras-applications-1.0.7.ebuild')
-rw-r--r--sci-libs/keras-applications/keras-applications-1.0.7.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sci-libs/keras-applications/keras-applications-1.0.7.ebuild b/sci-libs/keras-applications/keras-applications-1.0.7.ebuild
new file mode 100644
index 000000000000..dcf6a0b2bd09
--- /dev/null
+++ b/sci-libs/keras-applications/keras-applications-1.0.7.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python{3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="Keras deep learning library reference implementations of deep learning models"
+HOMEPAGE="https://keras.io/applications/"
+SRC_URI="https://github.com/keras-team/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"