summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-12-07 20:43:01 +0100
committerDavid Seifert <soap@gentoo.org>2022-12-07 20:43:01 +0100
commit525ac8b07e26c41a73a52068e07ea9f1a2dfb774 (patch)
tree396997306938bc7f8fb4a8841cd0943774efd9f4 /sci-libs/keras-applications/keras-applications-1.0.8-r2.ebuild
parentsci-libs/keras-preprocessing: update EAPI 6 -> 8 (diff)
downloadgentoo-525ac8b07e26c41a73a52068e07ea9f1a2dfb774.tar.gz
gentoo-525ac8b07e26c41a73a52068e07ea9f1a2dfb774.tar.bz2
gentoo-525ac8b07e26c41a73a52068e07ea9f1a2dfb774.zip
sci-libs/keras-applications: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/keras-applications/keras-applications-1.0.8-r2.ebuild')
-rw-r--r--sci-libs/keras-applications/keras-applications-1.0.8-r2.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/sci-libs/keras-applications/keras-applications-1.0.8-r2.ebuild b/sci-libs/keras-applications/keras-applications-1.0.8-r2.ebuild
new file mode 100644
index 000000000000..8baf6e78c0af
--- /dev/null
+++ b/sci-libs/keras-applications/keras-applications-1.0.8-r2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Keras deep learning library reference implementations of deep learning models"
+HOMEPAGE="https://keras.io/applications/"
+SRC_URI="https://github.com/keras-team/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"