summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-09-28 11:43:54 +0800
committerJason Zaman <perfinion@gentoo.org>2018-09-28 18:23:47 +0800
commit7f60e422b3aa1cbad9afe3ca3374325455b8bd0b (patch)
treee0faec9074d20a67f133306403c1d3faf2b4a8af /sci-libs/keras-preprocessing/keras-preprocessing-1.0.3.ebuild
parentdev-lua/luaossl: bump version to 20180708 (diff)
downloadgentoo-7f60e422b3aa1cbad9afe3ca3374325455b8bd0b.tar.gz
gentoo-7f60e422b3aa1cbad9afe3ca3374325455b8bd0b.tar.bz2
gentoo-7f60e422b3aa1cbad9afe3ca3374325455b8bd0b.zip
sci-libs/keras-preprocessing: bump 1.0.3
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'sci-libs/keras-preprocessing/keras-preprocessing-1.0.3.ebuild')
-rw-r--r--sci-libs/keras-preprocessing/keras-preprocessing-1.0.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-libs/keras-preprocessing/keras-preprocessing-1.0.3.ebuild b/sci-libs/keras-preprocessing/keras-preprocessing-1.0.3.ebuild
new file mode 100644
index 000000000000..fb4aa8c7c7c9
--- /dev/null
+++ b/sci-libs/keras-preprocessing/keras-preprocessing-1.0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python{3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Easy data preprocessing and data augmentation for deep learning models"
+HOMEPAGE="https://keras.io/"
+SRC_URI="https://github.com/keras-team/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"