summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-27 23:05:59 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-27 23:05:59 +0200
commit42775f6e9d272c0acd6e9600e691cc4049741aa6 (patch)
treea5be86ff98408b740a964aef712e7815e2a753b5 /sci-libs/klu/klu-1.3.9-r2.ebuild
parentgames-strategy/naev: Remove old 0.8.1 (diff)
downloadgentoo-42775f6e9d272c0acd6e9600e691cc4049741aa6.tar.gz
gentoo-42775f6e9d272c0acd6e9600e691cc4049741aa6.tar.bz2
gentoo-42775f6e9d272c0acd6e9600e691cc4049741aa6.zip
sci-libs/klu: Drop static-libs
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/klu/klu-1.3.9-r2.ebuild')
-rw-r--r--sci-libs/klu/klu-1.3.9-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-libs/klu/klu-1.3.9-r2.ebuild b/sci-libs/klu/klu-1.3.9-r2.ebuild
new file mode 100644
index 000000000000..3851e767c375
--- /dev/null
+++ b/sci-libs/klu/klu-1.3.9-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Sparse LU factorization for circuit simulation"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+DEPEND="
+ >=sci-libs/amd-2.4
+ >=sci-libs/btf-1.2
+ >=sci-libs/colamd-2.9"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.3.9-dash_doc.patch )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with doc)
+}
+
+src_install() {
+ default
+
+ # remove .la file
+ find "${ED}" -name '*.la' -delete || die
+}