summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-25 00:14:13 +0100
committerSam James <sam@gentoo.org>2023-08-25 00:14:13 +0100
commita3ab8231602c8af892facac582b5770f3834c21f (patch)
treee7799214785c340d7ee85001970218fc786b98f3 /sci-libs/lapack
parentprofiles/features/llvm: drop problematic LDFLAGS (diff)
downloadgentoo-a3ab8231602c8af892facac582b5770f3834c21f.tar.gz
gentoo-a3ab8231602c8af892facac582b5770f3834c21f.tar.bz2
gentoo-a3ab8231602c8af892facac582b5770f3834c21f.zip
sci-libs/lapack: use fortran-2.eclass
Not strictly related to bug #908798 but noticed while looking at it. Bug: https://bugs.gentoo.org/908798 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/lapack')
-rw-r--r--sci-libs/lapack/lapack-3.10.1.ebuild2
-rw-r--r--sci-libs/lapack/lapack-3.11.ebuild3
2 files changed, 3 insertions, 2 deletions
diff --git a/sci-libs/lapack/lapack-3.10.1.ebuild b/sci-libs/lapack/lapack-3.10.1.ebuild
index 218c49029127..16b9d22e73df 100644
--- a/sci-libs/lapack/lapack-3.10.1.ebuild
+++ b/sci-libs/lapack/lapack-3.10.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake fortran-2
DESCRIPTION="BLAS,CBLAS,LAPACK,LAPACKE reference implementations"
HOMEPAGE="https://www.netlib.org/lapack/"
diff --git a/sci-libs/lapack/lapack-3.11.ebuild b/sci-libs/lapack/lapack-3.11.ebuild
index 8d0bfc529500..72fc5a9ad67d 100644
--- a/sci-libs/lapack/lapack-3.11.ebuild
+++ b/sci-libs/lapack/lapack-3.11.ebuild
@@ -5,7 +5,7 @@ EAPI=8
# Some additional tests are run if Python is found
PYTHON_COMPAT=( python3_{9..11} )
-inherit cmake python-any-r1
+inherit cmake fortran-2 python-any-r1
DESCRIPTION="BLAS,CBLAS,LAPACK,LAPACKE reference implementations"
HOMEPAGE="https://www.netlib.org/lapack/"
@@ -34,6 +34,7 @@ BDEPEND="
"
pkg_setup() {
+ fortran-2_pkg_setup
use test && python-any-r1_pkg_setup
}