summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-02-28 21:25:22 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-03-02 12:20:44 -0500
commitd35f1c333b56f6552e3ab2dee44a0431e21c3522 (patch)
tree0efd208d2b73e3e99d77a59c8c89c49b58859eee /sci-libs/ldl/ldl-2.2.6.ebuild
parentsci-libs/btf: new version 1.2.6. (diff)
downloadgentoo-d35f1c333b56f6552e3ab2dee44a0431e21c3522.tar.gz
gentoo-d35f1c333b56f6552e3ab2dee44a0431e21c3522.tar.bz2
gentoo-d35f1c333b56f6552e3ab2dee44a0431e21c3522.zip
sci-libs/ldl: new version 2.2.6.
Update to EAPI=7 and fix the HOMEPAGE, SRC_URI, and LICENSE. This is part of a larger SuiteSparse v5.4.0 upgrade thanks to François Bissey whose sage-on-gentoo ebuilds I'm using. There's a newer release (v5.7.1) of SuiteSparse, but v5.4.0 has seen more testing. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/ldl/ldl-2.2.6.ebuild')
-rw-r--r--sci-libs/ldl/ldl-2.2.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sci-libs/ldl/ldl-2.2.6.ebuild b/sci-libs/ldl/ldl-2.2.6.ebuild
new file mode 100644
index 000000000000..6a1f2acf3873
--- /dev/null
+++ b/sci-libs/ldl/ldl-2.2.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple but educational LDL^T matrix factorization algorithm"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc static-libs"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+DEPEND="sci-libs/suitesparseconfig"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with doc) \
+ $(use_enable static-libs static)
+}