summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/ldl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/ldl')
-rw-r--r--sci-libs/ldl/Manifest2
-rw-r--r--sci-libs/ldl/files/ldl-2.0.3-autotools.patch64
-rw-r--r--sci-libs/ldl/ldl-2.0.4.ebuild31
-rw-r--r--sci-libs/ldl/ldl-2.1.0.ebuild28
-rw-r--r--sci-libs/ldl/metadata.xml16
5 files changed, 141 insertions, 0 deletions
diff --git a/sci-libs/ldl/Manifest b/sci-libs/ldl/Manifest
new file mode 100644
index 000000000000..76fdacc26f73
--- /dev/null
+++ b/sci-libs/ldl/Manifest
@@ -0,0 +1,2 @@
+DIST LDL-2.0.4.tar.gz 326840 SHA256 b699df725404d6f94871336f4f87d6f81c5e1921f7fb83e2287eb8f66443d1ac
+DIST ldl-2.1.0.tar.bz2 336442 SHA256 20a7182e499bdf17bf6ef016e5c97f1a2e83519ff84fe8a4f611438cfe557338 SHA512 ad532e3481e48b9c3587ca0cba3d58a89a2174e3a0d523dcac6d420e04aa5da1cb8517bb14556d0a593110350fdc02aea3677eec41eb74821a3a63552418d0b5 WHIRLPOOL ad00375ce9d71500bf2d39f468d8e4f887cf30b0f57f7e79f8a01c2fe35b0e32fdae8f6673ba2adb38ff816342793826839aa34d0a4bf15e24d26523c4ccdb82
diff --git a/sci-libs/ldl/files/ldl-2.0.3-autotools.patch b/sci-libs/ldl/files/ldl-2.0.3-autotools.patch
new file mode 100644
index 000000000000..5e174999a5f3
--- /dev/null
+++ b/sci-libs/ldl/files/ldl-2.0.3-autotools.patch
@@ -0,0 +1,64 @@
+--- configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2008-01-30 12:45:53.174426797 +0000
+@@ -0,0 +1,10 @@
++# -*- Autoconf -*-
++AC_PREREQ(2.59)
++AC_INIT(ldl, 2.0.3, davis@cise.ufl.edu)
++AM_INIT_AUTOMAKE([foreign])
++AC_PROG_INSTALL
++AC_PROG_LIBTOOL
++AC_CHECK_LIB(m, sqrt)
++AC_CHECK_HEADERS(UFconfig.h)
++AC_CONFIG_FILES([Makefile Source/Makefile Demo/Makefile])
++AC_OUTPUT
+--- Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2008-01-30 15:49:41.835515468 +0000
+@@ -0,0 +1,4 @@
++SUBDIRS = Source Demo
++EXTRA_DIST = README.txt
++include_HEADERS = Include/ldl.h
++
+--- Source/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Source/Makefile.am 2008-01-30 12:49:25.858546974 +0000
+@@ -0,0 +1,11 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++
++LDLSRC=ldl.c
++lib_LTLIBRARIES = libldl.la
++noinst_LTLIBRARIES = libldli.la libldll.la
++libldli_la_SOURCES = $(LDLSRC)
++libldli_la_CPPFLAGS = $(AM_CPPFLAGS)
++libldll_la_SOURCES = $(LDLSRC)
++libldll_la_CPPFLAGS = $(AM_CPPFLAGS) -DLDL_LONG
++libldl_la_SOURCES =
++libldl_la_LIBADD = libldll.la libldli.la
+--- Demo/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Demo/Makefile.am 2008-01-30 15:43:45.603214946 +0000
+@@ -0,0 +1,27 @@
++LDADD = $(top_builddir)/Source/libldl.la -lm
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++check_PROGRAMS = ldlsimple ldllsimple ldlmain ldllmain ldlamd ldllamd
++
++ldlmain_SOURCES = ldlmain.c
++ldllmain_SOURCES = ldlmain.c
++ldllmain_CPPFLAGS = $(AM_CPPFLAGS) -DLDL_LONG
++
++ldlsimple_SOURCES = ldlsimple.c
++ldllsimple_SOURCES = ldlsimple.c
++ldllsimple_CPPFLAGS = $(AM_CPPFLAGS) -DLDL_LONG
++
++ldlamd_SOURCES = ldlamd.c
++ldllamd_CPPFLAGS = $(AM_CPPFLAGS) -DUSE_AMD
++ldllamd_SOURCES = ldlamd.c
++ldllamd_CPPFLAGS = $(AM_CPPFLAGS) -DUSE_AMD -DLDL_LONG
++ldllamd_LDADD = $(LDADD) -lamd
++
++check-local: $(check_PROGRAMS)
++ @for i in $(check_PROGRAMS); do \
++ echo "Testing $$i"; \
++ ./$$i > my_$$i.out; \
++ if ! diff $$i.out my_$$i.out; then \
++ echo "Testing $$i failed"; \
++ exit 1; \
++ fi \
++ done;
diff --git a/sci-libs/ldl/ldl-2.0.4.ebuild b/sci-libs/ldl/ldl-2.0.4.ebuild
new file mode 100644
index 000000000000..9959e6aff97d
--- /dev/null
+++ b/sci-libs/ldl/ldl-2.0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+inherit autotools-utils
+
+MY_PN=LDL
+
+DESCRIPTION="Simple but educational LDL^T matrix factorization algorithm"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/ldl"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+DEPEND="sci-libs/ufconfig"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.3-autotools.patch )
+DOCS=( README.txt Doc/ChangeLog )
+
+S="${WORKDIR}/${MY_PN}"
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc Doc/ldl_userguide.pdf
+}
diff --git a/sci-libs/ldl/ldl-2.1.0.ebuild b/sci-libs/ldl/ldl-2.1.0.ebuild
new file mode 100644
index 000000000000..6ea1d7fb1f3e
--- /dev/null
+++ b/sci-libs/ldl/ldl-2.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Simple but educational LDL^T matrix factorization algorithm"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/ldl"
+SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc static-libs"
+
+RDEPEND="sci-libs/suitesparseconfig"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc)
+ )
+ autotools-utils_src_configure
+}
diff --git a/sci-libs/ldl/metadata.xml b/sci-libs/ldl/metadata.xml
new file mode 100644
index 000000000000..16d693b4d0f1
--- /dev/null
+++ b/sci-libs/ldl/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ LDL is a set of concise routines for factorizing symmetric
+ positive-definite sparse matrices, with some applicability to
+ symmetric indefinite matrices. Its primary purpose is to illustrate
+ much of the basic theory of sparse matrix algorithms in as concise a
+ code as possible, including an elegant new method of sparse symmetric
+ factorization that computes the factorization row-by-row but stores it
+ column-by-column. The entire symbolic and numeric factorization
+ consists of a total of only 49 lines of code. The package is written
+ in C, and includes a MATLAB interface.
+</longdescription>
+</pkgmetadata>