summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-16 03:13:34 +0000
committerSam James <sam@gentoo.org>2021-11-16 03:14:10 +0000
commit7bb5230e3762a0fb07d7af810349052860a36903 (patch)
tree30fcbac5181ef3d618c9de1505b011a6a8dab3ab /sci-libs/libcifpp/libcifpp-2.0.4-r1.ebuild
parentsci-chemistry/dssp: don't run useless (for downstream) cppcheck test (diff)
downloadgentoo-7bb5230e3762a0fb07d7af810349052860a36903.tar.gz
gentoo-7bb5230e3762a0fb07d7af810349052860a36903.tar.bz2
gentoo-7bb5230e3762a0fb07d7af810349052860a36903.zip
sci-libs/libcifpp: fix Boost dependency
We use Boost headers (=> DEPEND) and link against it (=> RDEPEND). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/libcifpp/libcifpp-2.0.4-r1.ebuild')
-rw-r--r--sci-libs/libcifpp/libcifpp-2.0.4-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/libcifpp/libcifpp-2.0.4-r1.ebuild b/sci-libs/libcifpp/libcifpp-2.0.4-r1.ebuild
new file mode 100644
index 000000000000..3064d4f1e9b0
--- /dev/null
+++ b/sci-libs/libcifpp/libcifpp-2.0.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Code to work with mmCIF and PDB files"
+HOMEPAGE="https://github.com/PDB-REDO/libcifpp"
+SRC_URI="
+ https://github.com/PDB-REDO/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ ftp://ftp.wwpdb.org/pub/pdb/data/monomers/components.cif.gz -> components-${PV}.cif.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=dev-libs/boost-1.70:=[threads(+)]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ cp "${WORKDIR}"/components-${PV}.cif data/components.cif || die
+
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DCIFPP_BUILD_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}