summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-04-14 19:48:59 +0100
committerJustin Lecher <jlec@gentoo.org>2017-04-14 19:59:59 +0100
commit867cd6b2da3eef8f3b11e3e7fb826eac9350ecef (patch)
tree30493bf72cc727e408ed2a25bd41be42e06d0e07 /sci-libs/libghemical/libghemical-3.0.0.ebuild
parentsci-libs/libexcelformat: Bump EAPI to 6 (diff)
downloadgentoo-867cd6b2da3eef8f3b11e3e7fb826eac9350ecef.tar.gz
gentoo-867cd6b2da3eef8f3b11e3e7fb826eac9350ecef.tar.bz2
gentoo-867cd6b2da3eef8f3b11e3e7fb826eac9350ecef.zip
sci-libs/libghemical: Bump EAPI to 6
Package-Manager: Portage-2.3.5, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs/libghemical/libghemical-3.0.0.ebuild')
-rw-r--r--sci-libs/libghemical/libghemical-3.0.0.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/sci-libs/libghemical/libghemical-3.0.0.ebuild b/sci-libs/libghemical/libghemical-3.0.0.ebuild
index dad5a06fbfc8..6e178a304743 100644
--- a/sci-libs/libghemical/libghemical-3.0.0.ebuild
+++ b/sci-libs/libghemical/libghemical-3.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
+EAPI=6
-inherit autotools eutils
+inherit autotools
DESCRIPTION="Chemical quantum mechanics and molecular mechanics"
HOMEPAGE="http://bioinformatics.org/ghemical/"
@@ -19,12 +19,15 @@ RDEPEND="
mpqc? (
>=sci-chemistry/mpqc-2.3.1-r1
virtual/blas
- virtual/lapack )"
+ virtual/lapack
+ )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
+PATCHES=( "${FILESDIR}"/${PN}-2.98-gl.patch )
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.98-gl.patch
+ default
eautoreconf
}
@@ -35,7 +38,3 @@ src_configure() {
$(use_enable mpqc) \
$(use_enable static-libs static)
}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
-}