summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-14 10:37:17 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-14 11:18:06 +0200
commit4cd22ec781b60c9f34512d79006f0d46e4d8e437 (patch)
tree5eb8f75c41d84a4a767cda207d6656767f90840e /sci-libs/libqalculate
parentmedia-sound/mixxx: depend on older scons (diff)
downloadgentoo-4cd22ec781b60c9f34512d79006f0d46e4d8e437.tar.gz
gentoo-4cd22ec781b60c9f34512d79006f0d46e4d8e437.tar.bz2
gentoo-4cd22ec781b60c9f34512d79006f0d46e4d8e437.zip
sci-libs/libqalculate: add 3.21.0
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sci-libs/libqalculate')
-rw-r--r--sci-libs/libqalculate/Manifest1
-rw-r--r--sci-libs/libqalculate/libqalculate-3.21.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sci-libs/libqalculate/Manifest b/sci-libs/libqalculate/Manifest
index 0f27049a628e..93d33565b63b 100644
--- a/sci-libs/libqalculate/Manifest
+++ b/sci-libs/libqalculate/Manifest
@@ -1 +1,2 @@
DIST libqalculate-3.20.1.tar.gz 2107300 BLAKE2B 79314cbe2adb183a17f96947b8ad4fa0bbfea665f7b9afda67785059e9bc0d94599b05cd55999302fc5e1216929b4ed98db4e2a6ae0c6fc74ebdd37dc6dcb72e SHA512 65a723c257c9e2419fc60ca254c23a7a7dd4d9a31beaa9c8fcf41a1e252e5f3be08e1160dcc72a0a407fe3ffd3e73353b141e40019871677a490d8c810c96931
+DIST libqalculate-3.21.0.tar.gz 2117414 BLAKE2B eaf8b886e716a6f8e9631dbda6533906cc7c5ed986233d75b9384aefb4123479914715d37268db5e1d403d1ee1835cde77314abe5380768fce5c266d1c253ca3 SHA512 7ca876ffe359ab2c6c6ae266007f489f9cd26f6650d6ace4e1d80cc660d16294cce601ed81046baca25cc4ec41668498af0a555fddc47c4118241e72af039614
diff --git a/sci-libs/libqalculate/libqalculate-3.21.0.ebuild b/sci-libs/libqalculate/libqalculate-3.21.0.ebuild
new file mode 100644
index 000000000000..65c9f8a2022c
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-3.21.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A modern multi-purpose calculator library"
+HOMEPAGE="https://qalculate.github.io/"
+SRC_URI="https://github.com/Qalculate/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/22"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="curl icu gnuplot readline"
+
+DEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libxml2:2
+ dev-libs/mpfr:0=
+ virtual/libiconv
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu:= )
+ readline? ( sys-libs/readline:0= )"
+RDEPEND="${DEPEND}
+ gnuplot? ( >=sci-visualization/gnuplot-3.7 )"
+BDEPEND="dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ cat >po/POTFILES.skip <<-EOF || die
+ # Required by make check
+ data/currencies.xml.in
+ data/datasets.xml.in
+ data/elements.xml.in
+ data/functions.xml.in
+ data/planets.xml.in
+ data/prefixes.xml.in
+ data/units.xml.in
+ data/variables.xml.in
+ src/defs2doc.cc
+ EOF
+}
+
+src_configure() {
+ # Needed for po-defs/Makefile
+ export CXX_FOR_BUILD="$(tc-getBUILD_CXX)"
+ export CXXCPP_FOR_BUILD="$(tc-getBUILD_CXX) -E"
+
+ # bug #792027
+ tc-export CC
+
+ econf \
+ --disable-static \
+ $(use_with curl libcurl) \
+ $(use_with gnuplot gnuplot-call) \
+ $(use_with icu) \
+ $(use_with readline)
+}
+
+src_install() {
+ # docs/reference/Makefile.am -> referencedir=
+ emake \
+ DESTDIR="${D}" \
+ referencedir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ install
+
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+}