summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2018-10-11 07:11:44 +0000
committerSven Wegener <swegener@gentoo.org>2018-10-11 07:13:17 +0000
commit79993520ea6a94649f9309f7121a513f529a20b8 (patch)
tree5d265f829c23198891a94e845c667c4c453dec82 /sci-libs/libsigrok
parentdev-lang/mono: bump to 5.16, drop multilib, clean old (diff)
downloadgentoo-79993520ea6a94649f9309f7121a513f529a20b8.tar.gz
gentoo-79993520ea6a94649f9309f7121a513f529a20b8.tar.bz2
gentoo-79993520ea6a94649f9309f7121a513f529a20b8.zip
sci-libs/libsigrok: Update icon cache and mime database
Signed-off-by: Sven Wegener <swegener@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'sci-libs/libsigrok')
-rw-r--r--sci-libs/libsigrok/libsigrok-0.5.0.ebuild14
-rw-r--r--sci-libs/libsigrok/libsigrok-9999.ebuild14
2 files changed, 24 insertions, 4 deletions
diff --git a/sci-libs/libsigrok/libsigrok-0.5.0.ebuild b/sci-libs/libsigrok/libsigrok-0.5.0.ebuild
index 2119698af8f7..66e5bbfb8146 100644
--- a/sci-libs/libsigrok/libsigrok-0.5.0.ebuild
+++ b/sci-libs/libsigrok/libsigrok-0.5.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
-inherit eutils python-single-r1 java-pkg-opt-2
+inherit eutils gnome2-utils python-single-r1 java-pkg-opt-2 xdg-utils
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="git://sigrok.org/${PN}"
@@ -80,3 +80,13 @@ src_install() {
default
prune_libtool_files
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/sci-libs/libsigrok/libsigrok-9999.ebuild b/sci-libs/libsigrok/libsigrok-9999.ebuild
index c3a463fbec8a..ef12e1f27924 100644
--- a/sci-libs/libsigrok/libsigrok-9999.ebuild
+++ b/sci-libs/libsigrok/libsigrok-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
-inherit eutils python-single-r1 java-pkg-opt-2
+inherit eutils gnome2-utils python-single-r1 java-pkg-opt-2 xdg-utils
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="git://sigrok.org/${PN}"
@@ -80,3 +80,13 @@ src_install() {
default
prune_libtool_files
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}