summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-24 14:48:20 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-24 14:48:20 +0100
commit7b071364b9b2537e541ee8c920e3c32431da14f6 (patch)
tree1159e18e7c3e65f6bba1c6bd9b49172ebe18be61 /sci-libs/libxc/libxc-5.1.0.ebuild
parentsci-libs/matio: Remove old (diff)
downloadgentoo-7b071364b9b2537e541ee8c920e3c32431da14f6.tar.gz
gentoo-7b071364b9b2537e541ee8c920e3c32431da14f6.tar.bz2
gentoo-7b071364b9b2537e541ee8c920e3c32431da14f6.zip
sci-libs/libxc: Bump to 5.1.0
Closes: https://github.com/gentoo/gentoo/pull/19179 Suggested-by: Horea Christian <chr@chymera.eu> Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/libxc/libxc-5.1.0.ebuild')
-rw-r--r--sci-libs/libxc/libxc-5.1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/libxc/libxc-5.1.0.ebuild b/sci-libs/libxc/libxc-5.1.0.ebuild
new file mode 100644
index 000000000000..bade5f34f401
--- /dev/null
+++ b/sci-libs/libxc/libxc-5.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools fortran-2
+
+DESCRIPTION="A library of exchange-correlation functionals for use in DFT"
+HOMEPAGE="https://octopus-code.org/wiki/Libxc"
+SRC_URI="https://gitlab.com/libxc/libxc/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="fortran test"
+RESTRICT="!test? ( test )"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --disable-static \
+ $(use_enable fortran)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -type f -delete || die
+}