summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-09 09:36:05 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-09 21:54:04 +0200
commit4eeb60fad01bf6833078fe630d160f39988dcf86 (patch)
treeb8c02d55a448ac84002a317699afb90a5e7040af /sci-libs/lis/lis-1.6.5.ebuild
parentsys-kernel/gentoo-sources: Linux patch 4.4.20 (diff)
downloadgentoo-4eeb60fad01bf6833078fe630d160f39988dcf86.tar.gz
gentoo-4eeb60fad01bf6833078fe630d160f39988dcf86.tar.bz2
gentoo-4eeb60fad01bf6833078fe630d160f39988dcf86.zip
sci-libs/lis: Version bump to 1.6.5
Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-libs/lis/lis-1.6.5.ebuild')
-rw-r--r--sci-libs/lis/lis-1.6.5.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/sci-libs/lis/lis-1.6.5.ebuild b/sci-libs/lis/lis-1.6.5.ebuild
new file mode 100644
index 000000000000..e5143116e924
--- /dev/null
+++ b/sci-libs/lis/lis-1.6.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools fortran-2 toolchain-funcs
+
+DESCRIPTION="Library of Iterative Solvers for Linear Systems"
+HOMEPAGE="http://www.ssisc.org/lis/index.en.html"
+SRC_URI="http://www.ssisc.org/lis/dl/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse2 doc fortran mpi openmp quad saamg static-libs"
+
+RDEPEND="mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6.2-autotools.patch )
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ if ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected compiler"
+
+ if tc-is-clang; then
+ ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
+ ewarn "which you will need to build ${CATEGORY}/${PN} with USE=\"openmp\""
+ fi
+
+ die "need openmp capable compiler"
+ fi
+ FORTRAN_NEED_OPENMP=1
+ fi
+
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable fortran) \
+ $(use_enable openmp omp) \
+ $(use_enable quad) \
+ $(use_enable "cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4)" fma) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable saamg) \
+ $(use_enable mpi)
+}
+
+src_install() {
+ use doc && DOCS+=( doc/*.pdf )
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}