summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/matio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/matio')
-rw-r--r--sci-libs/matio/Manifest2
-rw-r--r--sci-libs/matio/files/matio-1.5.0-asneeded.patch11
-rw-r--r--sci-libs/matio/matio-1.5.1.ebuild51
-rw-r--r--sci-libs/matio/matio-1.5.2.ebuild51
-rw-r--r--sci-libs/matio/metadata.xml15
5 files changed, 130 insertions, 0 deletions
diff --git a/sci-libs/matio/Manifest b/sci-libs/matio/Manifest
new file mode 100644
index 000000000000..e7dbf6da01fb
--- /dev/null
+++ b/sci-libs/matio/Manifest
@@ -0,0 +1,2 @@
+DIST matio-1.5.1.tar.gz 8160893 SHA256 7d94a1433f67ce21f08fbbfc8af677f3838964b2b07565dce6f65e878394cd2f SHA512 bd1e49bcbfe3e073d2339bc3dff803b222c007aad19759ee9b666438fa59ec2b2750b52ffb3b5e911145cf2977538447f5db977fc056a624c5878ddbcf564b26 WHIRLPOOL 54c5191c9b4b15e54f25d435a7ea680c84c94f1f5c9e432e3340a7a0821b743c95a08c4e77d65dece3768147c7b5e9e9057bc7ad9b8cde358951f5728d81879b
+DIST matio-1.5.2.tar.gz 8179926 SHA256 db02d0fb3373c3d766a606309b17e64a5d8da55610e921a9f1a0ec171e911d45 SHA512 47ee7457db3f2138ecb1db9d7a04bf91d8277024631694e5f5a49b77829d60ce9dd95a1db33cd8eeaa8271e942acf60b522f40e4d7f4cae90f0a7caee7eb6efc WHIRLPOOL 31796367020078b06cefa10ccfad00526a04c12c158f581d8b4c134071647f01ae55b39e1c738cc3a9ac6211f36cd59041130edd208f001a28fb9f770e0fe8b0
diff --git a/sci-libs/matio/files/matio-1.5.0-asneeded.patch b/sci-libs/matio/files/matio-1.5.0-asneeded.patch
new file mode 100644
index 000000000000..0f1e462c69f0
--- /dev/null
+++ b/sci-libs/matio/files/matio-1.5.0-asneeded.patch
@@ -0,0 +1,11 @@
+--- matio-1.5.0.orig/src/Makefile.am 2012-04-24 18:14:45.000000000 +0100
++++ matio-1.5.0/src/Makefile.am 2012-04-24 18:18:14.000000000 +0100
+@@ -45,7 +45,7 @@
+ lib_LTLIBRARIES = libmatio.la
+ libmatio_la_SOURCES = snprintf.c endian.c io.c $(ZLIB_SRC) read_data.c \
+ mat5.c mat4.c mat.c matvar_cell.c matvar_struct.c
+-libmatio_la_LIBADD = $(ZLIB_LIBS)
++libmatio_la_LIBADD = $(ZLIB_LIBS) $(HDF5_LIBS)
+
+ if MAT73
+ libmatio_la_SOURCES+= mat73.c
diff --git a/sci-libs/matio/matio-1.5.1.ebuild b/sci-libs/matio/matio-1.5.1.ebuild
new file mode 100644
index 000000000000..c567061f0b0b
--- /dev/null
+++ b/sci-libs/matio/matio-1.5.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Library for reading and writing matlab files"
+HOMEPAGE="http://sourceforge.net/projects/matio/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples hdf5 sparse static-libs"
+
+RDEPEND="
+ sys-libs/zlib
+ hdf5? ( sci-libs/hdf5 )"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.0-asneeded.patch )
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable hdf5 mat73)
+ $(use_enable sparse extended-sparse)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile -C documentation pdf
+}
+
+src_install() {
+ use doc && DOCS=( "${BUILD_DIR}"/documentation/matio_user_guide.pdf )
+ autotools-utils_src_install
+ if use examples; then
+ docinto examples
+ dodoc test/test*
+ insinto /usr/share/${PN}
+ doins share/test*
+ fi
+}
diff --git a/sci-libs/matio/matio-1.5.2.ebuild b/sci-libs/matio/matio-1.5.2.ebuild
new file mode 100644
index 000000000000..c567061f0b0b
--- /dev/null
+++ b/sci-libs/matio/matio-1.5.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Library for reading and writing matlab files"
+HOMEPAGE="http://sourceforge.net/projects/matio/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples hdf5 sparse static-libs"
+
+RDEPEND="
+ sys-libs/zlib
+ hdf5? ( sci-libs/hdf5 )"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.0-asneeded.patch )
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable hdf5 mat73)
+ $(use_enable sparse extended-sparse)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile -C documentation pdf
+}
+
+src_install() {
+ use doc && DOCS=( "${BUILD_DIR}"/documentation/matio_user_guide.pdf )
+ autotools-utils_src_install
+ if use examples; then
+ docinto examples
+ dodoc test/test*
+ insinto /usr/share/${PN}
+ doins share/test*
+ fi
+}
diff --git a/sci-libs/matio/metadata.xml b/sci-libs/matio/metadata.xml
new file mode 100644
index 000000000000..0b2480b9550d
--- /dev/null
+++ b/sci-libs/matio/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ matio is an ISO C library (with a limited Fortran 90 interface) for
+ reading and writing Matlab MAT files.
+</longdescription>
+ <use>
+ <flag name="sparse">Extend formats for sparse matrix (not matlab)</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">matio</remote-id>
+ </upstream>
+</pkgmetadata>