summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-21 22:21:08 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-21 22:21:08 +0100
commit5141be0b130e6706bee2869feaa8d7ee1c7cd3cf (patch)
tree378b1fd7603a162f9345e893a0cc4beaed2d713b /sci-libs/mpfi
parentgames-action/0verkill: Port to EAPI 7 (diff)
downloadgentoo-5141be0b130e6706bee2869feaa8d7ee1c7cd3cf.tar.gz
gentoo-5141be0b130e6706bee2869feaa8d7ee1c7cd3cf.tar.bz2
gentoo-5141be0b130e6706bee2869feaa8d7ee1c7cd3cf.zip
sci-libs/mpfi: bump to 1.5.4
Closes: https://bugs.gentoo.org/742560 Closes: https://github.com/gentoo/gentoo/pull/18327 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/mpfi')
-rw-r--r--sci-libs/mpfi/Manifest1
-rw-r--r--sci-libs/mpfi/mpfi-1.5.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sci-libs/mpfi/Manifest b/sci-libs/mpfi/Manifest
index e8c03ff1f9a6..6e2dfd16d376 100644
--- a/sci-libs/mpfi/Manifest
+++ b/sci-libs/mpfi/Manifest
@@ -1 +1,2 @@
DIST mpfi-1.5.3.tar.bz2 447256 BLAKE2B 67bb9af362ec96c015571cbdaba09befc2241e0113b6177dd76eec97b619bbf9c924ba4d16583df664cafdb1a78c8700712e30633e91e5ae6f1d5e084c3ede5c SHA512 9c3cdf665fccff8b383c96827f4acb7aa62efdf7854cff271455273f00f8e7ecf84fbe191b02e5f51fe067aaae564fd2a0add062070ff5c1f542d61a021f967d
+DIST mpfi-1.5.4.tgz 261696 BLAKE2B 264453870fbf18afc0876eef72a3fc9690e9eee1da5179831a24409159abe75b88dc373e2d20b8171c846e870ded876715b2c9034ab4f0d0f0ff10e34abd099d SHA512 72ba7d8c950f4d4e2c7a3da8570cdcec08f75b73580cdf64c4cc3b24f8add23c46ccf78a6de2158e81bd77e6efabceebbae418988d536e7484356b8102e10ce1
diff --git a/sci-libs/mpfi/mpfi-1.5.4.ebuild b/sci-libs/mpfi/mpfi-1.5.4.ebuild
new file mode 100644
index 000000000000..7c513767c675
--- /dev/null
+++ b/sci-libs/mpfi/mpfi-1.5.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Multiple precision interval arithmetic library based on MPFR"
+HOMEPAGE="http://perso.ens-lyon.fr/nathalie.revol/software.html"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/38111/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}