summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-09-07 13:53:50 -0400
committerMichael Orlitzky <mjo@gentoo.org>2021-09-07 13:54:41 -0400
commitc6902b80403a506ebe337818c849f7d468294927 (patch)
tree55ac2733533dcae5c5d834d1e5a5889c031b0205 /sci-libs/mumps
parentdev-python/pyzmq: stable 22.1.0 for sparc, bug #808339 (diff)
downloadgentoo-c6902b80403a506ebe337818c849f7d468294927.tar.gz
gentoo-c6902b80403a506ebe337818c849f7d468294927.tar.bz2
gentoo-c6902b80403a506ebe337818c849f7d468294927.zip
sci-libs/mumps: new revision to fix more underlinking.
When building without USE=mpi, the various lib*mumps libraries use LAPACK symbols without actually linking to liblapack. There are already a bunch of hacks in the mumps ebuild to work around these issues, so all I've done is add one more. As a simple test case, you can try to run the test suite for sci-libs/coinor-clp with USE="mumps metis", which now works. Closes: https://bugs.gentoo.org/777840 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/mumps')
-rw-r--r--sci-libs/mumps/mumps-5.3.5-r1.ebuild (renamed from sci-libs/mumps/mumps-5.3.5.ebuild)4
1 files changed, 4 insertions, 0 deletions
diff --git a/sci-libs/mumps/mumps-5.3.5.ebuild b/sci-libs/mumps/mumps-5.3.5-r1.ebuild
index 76f2dbe8d4d0..8f970661e820 100644
--- a/sci-libs/mumps/mumps-5.3.5.ebuild
+++ b/sci-libs/mumps/mumps-5.3.5-r1.ebuild
@@ -25,6 +25,7 @@ RDEPEND="
mpi? ( >=sci-libs/parmetis-4 )
)
mpi? ( sci-libs/scalapack )
+ !mpi? ( virtual/lapack )
scotch? ( >=sci-libs/scotch-6.0.1:=[mpi=] )
"
DEPEND="${RDEPEND}"
@@ -83,6 +84,8 @@ src_prepare() {
}
src_configure() {
+ # We abuse LIBADD here to work around the fact that MUMPS is criminally
+ # underlinked.
LIBADD="$($(tc-getPKG_CONFIG) --libs blas) -Llib -lpord"
local ord="-Dpord"
@@ -132,6 +135,7 @@ src_configure() {
-e "s;^\(SCALAP\s*=\).*;\1;" \
-e 's;^LIBSEQNEEDED =;LIBSEQNEEDED = libseqneeded;g' \
Makefile.inc || die
+ LIBADD="${LIBADD} $($(tc-getPKG_CONFIG) --libs lapack)"
export LINK="$(tc-getFC)"
fi
sed -i -e "s;^\s*\(ORDERINGSF\s*=\).*;\1 ${ord};" Makefile.inc || die