summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-09-06 13:41:26 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-06 22:10:55 +0200
commit347b05726522c6a5e49cf28c24085bc89dcba9d5 (patch)
tree454366de1ca4b2bee37373cd3e080a8f364683da /sci-libs/neartree/neartree-5.1.1.ebuild
parentsci-libs/neartree: Fix overlong DESCRIPTION (diff)
downloadgentoo-347b05726522c6a5e49cf28c24085bc89dcba9d5.tar.gz
gentoo-347b05726522c6a5e49cf28c24085bc89dcba9d5.tar.bz2
gentoo-347b05726522c6a5e49cf28c24085bc89dcba9d5.zip
sci-libs/neartree: Version bump to 5.1.1
* EAPI=6 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2255 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/neartree/neartree-5.1.1.ebuild')
-rw-r--r--sci-libs/neartree/neartree-5.1.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/neartree/neartree-5.1.1.ebuild b/sci-libs/neartree/neartree-5.1.1.ebuild
new file mode 100644
index 000000000000..794d1647ba62
--- /dev/null
+++ b/sci-libs/neartree/neartree-5.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+MY_PN=NearTree
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Function library efficiently solving the Nearest Neighbor Problem"
+HOMEPAGE="http://neartree.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/cvector"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+}
+
+src_configure() {
+ local mycmakeargs=( -DDOC_DIR="${EPREFIX}/usr/share/doc/${PF}" )
+ cmake-utils_src_configure
+}