summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-21 18:09:59 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-24 19:32:42 +0000
commitf11431778bc47cc44a32964f280fd579c875796c (patch)
tree16fd9e9b3641a78bf792dc76a73761b6d3e0616c /sci-libs/o2scl/o2scl-0.920.ebuild
parentsys-libs/libcxx: Fix live conditions in 5.0.9999 (diff)
downloadgentoo-f11431778bc47cc44a32964f280fd579c875796c.tar.gz
gentoo-f11431778bc47cc44a32964f280fd579c875796c.tar.bz2
gentoo-f11431778bc47cc44a32964f280fd579c875796c.zip
sci-libs/o2scl: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sci-libs/o2scl/o2scl-0.920.ebuild')
-rw-r--r--sci-libs/o2scl/o2scl-0.920.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/sci-libs/o2scl/o2scl-0.920.ebuild b/sci-libs/o2scl/o2scl-0.920.ebuild
new file mode 100644
index 000000000000..bf2fa4a38a83
--- /dev/null
+++ b/sci-libs/o2scl/o2scl-0.920.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Object-oriented Scientific Computing Library"
+HOMEPAGE="http://web.utk.edu/~asteine1/o2scl"
+SRC_URI="https://github.com/awsteiner/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="armadillo debug doc examples eigen fftw gsl hdf5 openmp readline static-libs"
+
+RDEPEND="
+ dev-libs/boost:0=
+ >=sci-libs/gsl-2:0=
+ virtual/cblas:=
+ eigen? ( dev-cpp/eigen:3 )
+ armadillo? ( sci-libs/armadillo[lapack] )
+ fftw? ( sci-libs/fftw:3.0= )
+ hdf5? ( sci-libs/hdf5:0= )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp && ! tc-check-openmp; then
+ ewarn "OpenMP is not available in your current selected compiler"
+ die "need openmp capable compiler"
+ fi
+}
+
+src_configure() {
+ use debug || append-cppflags -DO2SCL_NO_RANGE_CHECK
+ econf \
+ --enable-acol \
+ $(use_enable armadillo) \
+ $(use_enable eigen) \
+ $(use_enable fftw) \
+ $(use_enable gsl gsl2) \
+ $(use_enable hdf5 hdf) \
+ $(use_enable hdf5 partlib) \
+ $(use_enable hdf5 eoslib) \
+ $(use_enable openmp) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+ rm -r "${ED}"/usr/doc || die
+ if use doc; then
+ dodoc -r doc/o2scl/html
+ docompress -x /usr/share/doc/${PF}/html
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}