summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-06-07 09:08:05 +0200
committerMichael Weber <xmw@gentoo.org>2017-06-07 09:09:40 +0200
commit29c93fad765e6a21197b9e8cb6c3b2df2c037ab8 (patch)
treea66beef4d8810a60e16d2eaf39a1e7b4e1f3c5bd /sci-libs/opencascade/files
parentmedia-gfx/feh: version bump to 2.19 (diff)
downloadgentoo-29c93fad765e6a21197b9e8cb6c3b2df2c037ab8.tar.gz
gentoo-29c93fad765e6a21197b9e8cb6c3b2df2c037ab8.tar.bz2
gentoo-29c93fad765e6a21197b9e8cb6c3b2df2c037ab8.zip
sci-libs/opencascade: Revbump with patches for >=sci-libs/vtk-6.3 (thanks Juergen Rose, bug 605304). EAPI 6.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sci-libs/opencascade/files')
-rw-r--r--sci-libs/opencascade/files/opencascade-6.9.1-vtk-6.3.patch70
-rw-r--r--sci-libs/opencascade/files/opencascade-6.9.1-vtk-configure.patch13
2 files changed, 83 insertions, 0 deletions
diff --git a/sci-libs/opencascade/files/opencascade-6.9.1-vtk-6.3.patch b/sci-libs/opencascade/files/opencascade-6.9.1-vtk-6.3.patch
new file mode 100644
index 000000000000..e6b011b1e03b
--- /dev/null
+++ b/sci-libs/opencascade/files/opencascade-6.9.1-vtk-6.3.patch
@@ -0,0 +1,70 @@
+--- work/opencascade-6.9.1/configure.ac
++++ work/opencascade-6.9.1/configure.ac
+@@ -1044,7 +1044,7 @@
+ fi
+ if test "x$vtk_lib" != "x"; then
+ CSF_VTK_LIB="-L$vtk_lib -lvtkCommonCore -lvtkCommonDataModel -lvtkCommonExecutionModel -lvtkCommonMath -lvtkCommonTransforms "
+- CSF_VTK_LIB="${CSF_VTK_LIB} -lvtkRenderingCore -lvtkRenderingOpenGL -lvtkFiltersGeneral -lvtkIOCore -lvtkIOImage -lvtkImagingCore -lvtkInteractionStyle "
++ CSF_VTK_LIB="${CSF_VTK_LIB} -lvtkRenderingCore -lvtkRenderingOpenGL2 -lvtkFiltersGeneral -lvtkIOCore -lvtkIOImage -lvtkImagingCore -lvtkInteractionStyle "
+ else
+ HAVE_VTK=no
+ fi
+--- opencascade-6.9.1/src/IVtkVTK/IVtkVTK_View.cxx
++++ opencascade-6.9.1/src/IVtkVTK/IVtkVTK_View.cxx
+@@ -151,7 +151,7 @@ bool IVtkVTK_View::DisplayToWorld (const gp_XY& theDisplayPnt, gp_XYZ& theWorldP
+ myRenderer->SetDisplayPoint (theDisplayPnt.X(), theDisplayPnt.Y(), 0.0);
+ myRenderer->DisplayToWorld();
+
+- vtkFloatingPointType* const aCoords = myRenderer->GetWorldPoint();
++ double* const aCoords = myRenderer->GetWorldPoint();
+ if (aCoords[3] == 0.0) // Point at infinity in homogeneous coordinates
+ {
+ return false;
+--- opencascade-6.9.1/src/IVtkTools/IVtkTools_ShapePicker.cxx
++++ opencascade-6.9.1/src/IVtkTools/IVtkTools_ShapePicker.cxx
+@@ -73,15 +73,15 @@ float IVtkTools_ShapePicker::GetTolerance( ) const
+ // Method: convertDisplayToWorld
+ // Purpose: Convert display coordinates to world coordinates
+ //============================================================================
+-bool IVtkTools_ShapePicker::convertDisplayToWorld (vtkRenderer *theRenderer,
+- vtkFloatingPointType theDisplayCoord[3],
+- vtkFloatingPointType theWorldCoord[3])
++bool IVtkTools_ShapePicker::convertDisplayToWorld (vtkRenderer *theRenderer,
++ double theDisplayCoord[3],
++ double theWorldCoord[3])
+ {
+ // Convert the selection point into world coordinates.
+ theRenderer->SetDisplayPoint (theDisplayCoord[0], theDisplayCoord[1], theDisplayCoord[2]);
+ theRenderer->DisplayToWorld();
+
+- vtkFloatingPointType* const aCoords = theRenderer->GetWorldPoint();
++ double* const aCoords = theRenderer->GetWorldPoint();
+ if (aCoords[3] == 0.0)
+ {
+ return false;
+--- opencascade-6.9.1/src/IVtkTools/IVtkTools_ShapePicker.hxx
++++ opencascade-6.9.1/src/IVtkTools/IVtkTools_ShapePicker.hxx
+@@ -124,8 +124,8 @@ protected:
+
+ //! Convert display coordinates to world coordinates
+ static bool convertDisplayToWorld (vtkRenderer *theRenderer,
+- vtkFloatingPointType theDisplayCoord[3],
+- vtkFloatingPointType theWorldCoord[3] );
++ double theDisplayCoord[3],
++ double theWorldCoord[3] );
+
+ private: // not copyable
+ IVtkTools_ShapePicker (const IVtkTools_ShapePicker&);
+--- opencascade-6.9.1/inc/IVtkTools_ShapePicker.hxx
++++ opencascade-6.9.1/inc/IVtkTools_ShapePicker.hxx
+@@ -124,8 +124,8 @@
+
+ //! Convert display coordinates to world coordinates
+ static bool convertDisplayToWorld (vtkRenderer *theRenderer,
+- vtkFloatingPointType theDisplayCoord[3],
+- vtkFloatingPointType theWorldCoord[3] );
++ double theDisplayCoord[3],
++ double theWorldCoord[3] );
+
+ private: // not copyable
+ IVtkTools_ShapePicker (const IVtkTools_ShapePicker&);
diff --git a/sci-libs/opencascade/files/opencascade-6.9.1-vtk-configure.patch b/sci-libs/opencascade/files/opencascade-6.9.1-vtk-configure.patch
new file mode 100644
index 000000000000..3c2711d3813e
--- /dev/null
+++ b/sci-libs/opencascade/files/opencascade-6.9.1-vtk-configure.patch
@@ -0,0 +1,13 @@
+--- opencascade-6.9.1/configure.ac
++++ opencascade-6.9.1/configure.ac
+@@ -1043,8 +1043,8 @@
+ HAVE_VTK=no
+ fi
+ if test "x$vtk_lib" != "x"; then
+- CSF_VTK_LIB="-L$vtk_lib -lvtkCommonCore-6.1 -lvtkCommonDataModel-6.1 -lvtkCommonExecutionModel-6.1 -lvtkCommonMath-6.1 -lvtkCommonTransforms-6.1 "
+- CSF_VTK_LIB="${CSF_VTK_LIB} -lvtkRenderingCore-6.1 -lvtkRenderingOpenGL-6.1 -lvtkFiltersGeneral-6.1 -lvtkIOCore-6.1 -lvtkIOImage-6.1 -lvtkImagingCore-6.1 -lvtkInteractionStyle-6.1 "
++ CSF_VTK_LIB="-L$vtk_lib -lvtkCommonCore -lvtkCommonDataModel -lvtkCommonExecutionModel -lvtkCommonMath -lvtkCommonTransforms "
++ CSF_VTK_LIB="${CSF_VTK_LIB} -lvtkRenderingCore -lvtkRenderingOpenGL -lvtkFiltersGeneral -lvtkIOCore -lvtkIOImage -lvtkImagingCore -lvtkInteractionStyle "
+ else
+ HAVE_VTK=no
+ fi