summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-12-18 19:27:03 +0000
committerJustin Lecher <jlec@gentoo.org>2017-12-18 19:40:17 +0000
commit85f96e014d0e2355a2f3165fc04e035617fa68ea (patch)
treebd0414027864267cae23f999c42d3de825650478 /sci-libs/parmgridgen/parmgridgen-1.0-r1.ebuild
parentsci-chemistry/xdsstat-bin: Bump to new hash algos (diff)
downloadgentoo-85f96e014d0e2355a2f3165fc04e035617fa68ea.tar.gz
gentoo-85f96e014d0e2355a2f3165fc04e035617fa68ea.tar.bz2
gentoo-85f96e014d0e2355a2f3165fc04e035617fa68ea.zip
sci-libs/parmgridgen: Bump to EAPI=6
* fix format security * fix for new hash algos Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-libs/parmgridgen/parmgridgen-1.0-r1.ebuild')
-rw-r--r--sci-libs/parmgridgen/parmgridgen-1.0-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-libs/parmgridgen/parmgridgen-1.0-r1.ebuild b/sci-libs/parmgridgen/parmgridgen-1.0-r1.ebuild
new file mode 100644
index 000000000000..c94cad2a63ac
--- /dev/null
+++ b/sci-libs/parmgridgen/parmgridgen-1.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MYP=ParMGridGen-${PV}
+
+DESCRIPTION="Software for parallel (mpi) generating coarse grids"
+HOMEPAGE="http://www-users.cs.umn.edu/~moulitsa/software.html"
+SRC_URI="http://www-users.cs.umn.edu/~moulitsa/download/${MYP}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RESTRICT="mirror bindist"
+
+DEPEND="virtual/mpi"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MYP}
+
+pkg_setup(){
+ export CC=mpicc
+}
+
+PATCHES=(
+ "${FILESDIR}/${P}-autotools.patch"
+ "${FILESDIR}/${P}-as-needed.patch"
+ "${FILESDIR}/${P}-format-security.patch"
+ "${FILESDIR}/${P}-impl-fct.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc README Doc/*.pdf
+}