summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-19 12:25:38 +0000
committerSam James <sam@gentoo.org>2021-02-19 12:44:55 +0000
commitb7d866832648a6b46866e0d0aff5f96b1d9b5f34 (patch)
treef7da449aca666f6ee5df3572271685f4718a1fd5 /sci-libs/pgplot/pgplot-5.2.2-r7.ebuild
parentmedia-plugins/hdx-realtime-media-engine: Bump to version 2.9.300.2604 (diff)
downloadgentoo-b7d866832648a6b46866e0d0aff5f96b1d9b5f34.tar.gz
gentoo-b7d866832648a6b46866e0d0aff5f96b1d9b5f34.tar.bz2
gentoo-b7d866832648a6b46866e0d0aff5f96b1d9b5f34.zip
sci-libs/pgplot: workaround gcc 10 (fortran) failure
Closes: https://bugs.gentoo.org/722190 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/pgplot/pgplot-5.2.2-r7.ebuild')
-rw-r--r--sci-libs/pgplot/pgplot-5.2.2-r7.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sci-libs/pgplot/pgplot-5.2.2-r7.ebuild b/sci-libs/pgplot/pgplot-5.2.2-r7.ebuild
index 43b17b8974b1..b1c5b83d6d54 100644
--- a/sci-libs/pgplot/pgplot-5.2.2-r7.ebuild
+++ b/sci-libs/pgplot/pgplot-5.2.2-r7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils fortran-2 toolchain-funcs
+inherit eutils fortran-2 flag-o-matic toolchain-funcs
MY_P="${PN}${PV//.}"
@@ -78,6 +78,10 @@ src_prepare() {
}
src_configure() {
+ # GCC 10 workaround
+ # bug #722190
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
./makemake . linux
# post makefile creation prefix hack
sed -i -e "s|/usr|${EPREFIX}/usr|g" makefile || die