summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/plotmm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/plotmm')
-rw-r--r--sci-libs/plotmm/Manifest1
-rw-r--r--sci-libs/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch100
-rw-r--r--sci-libs/plotmm/metadata.xml10
-rw-r--r--sci-libs/plotmm/plotmm-0.1.2.ebuild62
4 files changed, 173 insertions, 0 deletions
diff --git a/sci-libs/plotmm/Manifest b/sci-libs/plotmm/Manifest
new file mode 100644
index 000000000000..5fbfd4b2f353
--- /dev/null
+++ b/sci-libs/plotmm/Manifest
@@ -0,0 +1 @@
+DIST plotmm-0.1.2.tar.gz 473175 SHA256 896bb729eb9cad5f3188d72304789dd7a86fdae66020ac0632fe3bc66abe9653
diff --git a/sci-libs/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch b/sci-libs/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch
new file mode 100644
index 000000000000..a9aa53190d5f
--- /dev/null
+++ b/sci-libs/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch
@@ -0,0 +1,100 @@
+diff -ur plotmm-0.1.2-old/plotmm/compat.h plotmm-0.1.2/plotmm/compat.h
+--- plotmm-0.1.2-old/plotmm/compat.h 2005-11-09 17:36:02.000000000 +0100
++++ plotmm-0.1.2/plotmm/compat.h 2008-07-25 00:13:55.000000000 +0200
+@@ -58,7 +58,7 @@
+ #else
+
+ namespace PlotMM {
+- typedef SigC::ObjectBase ObjectBase;
++ typedef sigc::ObjectBase ObjectBase;
+ }
+
+ #endif
+diff -ur plotmm-0.1.2-old/plotmm/curve.h plotmm-0.1.2/plotmm/curve.h
+--- plotmm-0.1.2-old/plotmm/curve.h 2005-11-09 17:47:21.000000000 +0100
++++ plotmm-0.1.2/plotmm/curve.h 2008-07-25 00:24:02.000000000 +0200
+@@ -140,7 +140,7 @@
+ int from = 0, int to = -1);
+
+ //! Signals that this curve has changed in some way or the other
+- SigC::Signal0<void> signal_curve_changed;
++ sigc::signal0<void> signal_curve_changed;
+
+ protected:
+ virtual void init(const Glib::ustring &title);
+diff -ur plotmm-0.1.2-old/plotmm/plot.cc plotmm-0.1.2/plotmm/plot.cc
+--- plotmm-0.1.2-old/plotmm/plot.cc 2005-11-09 17:59:48.000000000 +0100
++++ plotmm-0.1.2/plotmm/plot.cc 2008-07-25 00:24:30.000000000 +0200
+@@ -322,7 +322,7 @@
+ connect(sigc::mem_fun(*this,&Plot::on_canvas_expose_event));
+ #else
+ canvas_.signal_expose_event().
+- connect(SigC::slot(*this,&Plot::on_canvas_expose_event));
++ connect(sigc::slot(*this,&Plot::on_canvas_expose_event));
+ #endif
+
+ show_all();
+@@ -406,19 +406,19 @@
+ }
+
+ //! Return the signal owned by plot canvas
+-SigC::Signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_press()
++sigc::signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_press()
+ {
+ return canvas_.signal_plot_mouse_press;
+ }
+
+ //! Return the signal owned by plot canvas
+-SigC::Signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_release()
++sigc::signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_release()
+ {
+ return canvas_.signal_plot_mouse_release;
+ }
+
+ //! Return the signal owned by plot canvas
+-SigC::Signal3<void,int,int,GdkEventMotion*> Plot::signal_plot_mouse_move()
++sigc::signal3<void,int,int,GdkEventMotion*> Plot::signal_plot_mouse_move()
+ {
+ return canvas_.signal_plot_mouse_move;
+ }
+diff -ur plotmm-0.1.2-old/plotmm/plot.h plotmm-0.1.2/plotmm/plot.h
+--- plotmm-0.1.2-old/plotmm/plot.h 2004-03-09 10:51:55.000000000 +0100
++++ plotmm-0.1.2/plotmm/plot.h 2008-07-25 00:25:17.000000000 +0200
+@@ -79,9 +79,9 @@
+ virtual void clear();
+ virtual void end_replot();
+
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press;
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release;
+- SigC::Signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move;
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press;
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release;
++ sigc::signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move;
+
+ protected:
+ virtual bool on_expose_event(GdkEventExpose* event);
+@@ -141,9 +141,9 @@
+ Scale *scale(PlotAxisID id) { return tickMark_[id]; }
+ PlotLabel *label(PlotAxisID id) { return axisLabel_[id]; }
+
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press();
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release();
+- SigC::Signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move();
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press();
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release();
++ sigc::signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move();
+
+ void set_selection(const Rectangle &r);
+ Rectangle get_selection() { return select_; }
+diff -ur plotmm-0.1.2-old/plotmm/scale.h plotmm-0.1.2/plotmm/scale.h
+--- plotmm-0.1.2-old/plotmm/scale.h 2004-03-05 16:25:43.000000000 +0100
++++ plotmm-0.1.2/plotmm/scale.h 2008-07-25 00:25:30.000000000 +0200
+@@ -133,7 +133,7 @@
+ /*! This signal is thrown whenever the scale is enabled or disabled
+ * \sa set_enabled, enabled
+ */
+- SigC::Signal1<void,bool> signal_enabled;
++ sigc::signal1<void,bool> signal_enabled;
+
+ protected:
+ virtual void on_realize();
diff --git a/sci-libs/plotmm/metadata.xml b/sci-libs/plotmm/metadata.xml
new file mode 100644
index 000000000000..77d8685c7897
--- /dev/null
+++ b/sci-libs/plotmm/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">plotmm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/plotmm/plotmm-0.1.2.ebuild b/sci-libs/plotmm/plotmm-0.1.2.ebuild
new file mode 100644
index 000000000000..6308ad48aa67
--- /dev/null
+++ b/sci-libs/plotmm/plotmm-0.1.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Plot widget for GTKmm"
+HOMEPAGE="http://plotmm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-cpp/gtkmm:2.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# NOTES:
+# somewhat, there is a dep on libsigc++ but it's much more via gtkmm
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-libsigc++-2.2.patch"
+
+ if ! use examples; then
+ sed -i -e "s:examples::" Makefile.in || die "sed failed"
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-maintainer-mode \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ --disable-libtool-lock
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+
+ if use doc; then
+ dohtml -r doc/html/* || die "dohtml failed"
+ fi
+
+ if use examples; then
+ # rename installed bin files
+ mv "${D}"/usr/bin/curves "${D}"/usr/bin/${PN}-curves || die "mv failed"
+ mv "${D}"/usr/bin/simple "${D}"/usr/bin/${PN}-simple || die "mv failed"
+
+ # install sources
+ insinto /usr/share/doc/${PF}/examples/
+ doins examples/{curves/curves,simple/simple}.cc || die "doins failed"
+
+ elog "You can use examples by calling ${PN}-curves or ${PN}-simple."
+ elog "Examples source code is in /usr/share/doc/${PF}/examples."
+ fi
+}