summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-12 11:57:34 +0000
committerSam James <sam@gentoo.org>2021-01-12 12:02:32 +0000
commit89055cbdc93283958495af044adf548b8082156a (patch)
tree2202aaf18b88c4aea489ae07162b4760c5452dc5 /sci-libs/proj/proj-7.2.1.ebuild
parentnet-ftp/atftp: Add -r addressing CVE 2020-6097 (diff)
downloadgentoo-89055cbdc93283958495af044adf548b8082156a.tar.gz
gentoo-89055cbdc93283958495af044adf548b8082156a.tar.bz2
gentoo-89055cbdc93283958495af044adf548b8082156a.zip
sci-libs/proj: bump to 19.2.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/proj/proj-7.2.1.ebuild')
-rw-r--r--sci-libs/proj/proj-7.2.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-libs/proj/proj-7.2.1.ebuild b/sci-libs/proj/proj-7.2.1.ebuild
new file mode 100644
index 000000000000..1228ef8a650d
--- /dev/null
+++ b/sci-libs/proj/proj-7.2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DATUMGRID="${PN}-datumgrid-1.8.tar.gz"
+EUROPE_DATUMGRID="${PN}-datumgrid-europe-1.6.tar.gz"
+
+DESCRIPTION="PROJ coordinate transformation software"
+HOMEPAGE="https://proj4.org/"
+SRC_URI="
+ https://download.osgeo.org/proj/${P}.tar.gz
+ https://download.osgeo.org/proj/${DATUMGRID}
+ europe? ( https://download.osgeo.org/proj/${EUROPE_DATUMGRID} )
+"
+
+LICENSE="MIT"
+SLOT="0/19"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="curl europe static-libs test +tiff"
+REQUIRED_USE="test? ( !europe )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-db/sqlite:3
+ curl? ( net-misc/curl )
+ tiff? ( media-libs/tiff )
+"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"/data || die
+ mv README README.DATA || die
+ unpack ${DATUMGRID}
+ use europe && unpack ${EUROPE_DATUMGRID}
+}
+
+src_configure() {
+ econf \
+ $(use_with curl) \
+ $(use_enable static-libs static) \
+ $(use_enable tiff)
+}
+
+src_install() {
+ default
+ cd data || die
+ dodoc README.{DATA,DATUMGRID}
+ use europe && dodoc README.EUROPE
+ find "${ED}" -name '*.la' -type f -delete || die
+}