summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-03-13 19:50:37 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-13 19:50:37 +0100
commit21ea3a9c387fa58d802162b465f57770d4f4e8ea (patch)
tree6fe211b0d0e28b2ad7fe967f11c4504ed2b5ab79 /sci-libs/punc
parentsci-libs/gamer: Port to EAPI 7 (diff)
downloadgentoo-21ea3a9c387fa58d802162b465f57770d4f4e8ea.tar.gz
gentoo-21ea3a9c387fa58d802162b465f57770d4f4e8ea.tar.bz2
gentoo-21ea3a9c387fa58d802162b465f57770d4f4e8ea.zip
sci-libs/punc: Port to EAPI 7
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/punc')
-rw-r--r--sci-libs/punc/punc-1.5.ebuild71
1 files changed, 33 insertions, 38 deletions
diff --git a/sci-libs/punc/punc-1.5.ebuild b/sci-libs/punc/punc-1.5.ebuild
index ccf2b1cc1733..2bb21a1e7e5a 100644
--- a/sci-libs/punc/punc-1.5.ebuild
+++ b/sci-libs/punc/punc-1.5.ebuild
@@ -1,20 +1,19 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils fortran-2 multilib toolchain-funcs
+inherit autotools fortran-2 toolchain-funcs
DESCRIPTION="Portable Understructure for Numerical Computing"
HOMEPAGE="http://fetk.org/codes/punc/index.html"
SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug doc mpi static-libs"
+IUSE="debug doc mpi"
RDEPEND="
dev-libs/maloc[mpi=]
@@ -27,64 +26,60 @@ RDEPEND="
virtual/blas
virtual/lapack
mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
doc? (
media-gfx/graphviz
- app-doc/doxygen )"
-
-S="${WORKDIR}/${PN}"
+ app-doc/doxygen
+ )"
PATCHES=(
"${FILESDIR}"/${PV}-linking.patch
"${FILESDIR}"/1.4-doc.patch
- )
+)
src_prepare() {
sed 's:punc/slu_ddefs.h:superlu/slu_ddefs.h:g' src/superlu/punc/vsuperlu.h > vsuperlu.h || die
sed 's:punc/umfpack.h:umfpack.h:g' src/umfpack/punc/vumfpack.h > vumfpack.h || die
- rm -rf src/{amd,blas,lapack,arpack,superlu,umfpack}
+ rm -r src/{amd,blas,lapack,arpack,superlu,umfpack} || die
- cp tools/tests/pmg/*.f src/pmg/ -f || die
- cp tools/tests/pmg/*.c src/pmg/ -f || die
+ cp -f tools/tests/pmg/*.f src/pmg/ || die
+ cp -f tools/tests/pmg/*.c src/pmg/ || die
cp src/pmg/vpmg.h src/vf2c/punc/vpmg.h || die
- autotools-utils_src_prepare
+ default
+ eautoreconf
}
src_configure() {
- local fetk_include
- local fetk_lib
- local myeconfargs
-
- use doc || myeconfargs+=( --with-doxygen= --with-dot= )
+ export FETK_INCLUDE="${ESYSROOT}"/usr/include
+ export FETK_LIBRARY="${ESYSROOT}"/usr/$(get_libdir)
- fetk_include="${EPREFIX}"/usr/include
- fetk_lib="${EPREFIX}"/usr/$(get_libdir)
- export FETK_INCLUDE="${fetk_include}"
- export FETK_LIBRARY="${fetk_lib}"
export FETK_LAPACK_LIBRARY="$($(tc-getPKG_CONFIG) --libs lapack)"
- export FETK_BLAS_LIBRARY="${fetk_lib}"
+ export FETK_BLAS_LIBRARY="${FETK_LIBRARY}"
export FETK_SUPERLU_LIBRARY="$($(tc-getPKG_CONFIG) --libs superlu)"
- export FETK_ARPACK_LIBRARY="${fetk_lib}"
- export FETK_UMFPACK_LIBRARY="${fetk_lib}"
- export FETK_CGCODE_LIBRARY="${fetk_lib}"
- export FETK_AMD_LIBRARY="${fetk_lib}"
-
- myeconfargs+=(
+ export FETK_ARPACK_LIBRARY="${FETK_LIBRARY}"
+ export FETK_UMFPACK_LIBRARY="${FETK_LIBRARY}"
+ export FETK_CGCODE_LIBRARY="${FETK_LIBRARY}"
+ export FETK_AMD_LIBRARY="${FETK_LIBRARY}"
+
+ econf \
+ --enable-vf2cforce \
+ --disable-static \
+ --disable-triplet \
+ --with-doxygen=$(usex doc "${BROOT}"/usr/bin/doxygen '') \
+ --with-dot=$(usex doc "${BROOT}"/usr/bin/dot '') \
$(use_enable debug vdebug)
- --enable-vf2cforce
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
- --disable-triplet
- )
- autotools-utils_src_configure
}
src_install() {
- autotools-utils_src_install
+ HTML_DOCS=( doc/index.html )
+ default
insinto /usr/include/punc
doins v*.h
- dohtml doc/index.html
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}