summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2021-04-18 16:35:33 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2021-04-18 16:35:33 +0200
commit9d3548c6ea17e18a0da3d8be97df25161092704e (patch)
treedca3b0b18e1b8f4e9f5341c54c255af723ff00ca /sci-libs/pyshp/pyshp-2.1.3.ebuild
parentmedia-radio/xlog: Version bump (diff)
downloadgentoo-9d3548c6ea17e18a0da3d8be97df25161092704e.tar.gz
gentoo-9d3548c6ea17e18a0da3d8be97df25161092704e.tar.bz2
gentoo-9d3548c6ea17e18a0da3d8be97df25161092704e.zip
sci-libs/pyshp: Version bump
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'sci-libs/pyshp/pyshp-2.1.3.ebuild')
-rw-r--r--sci-libs/pyshp/pyshp-2.1.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-libs/pyshp/pyshp-2.1.3.ebuild b/sci-libs/pyshp/pyshp-2.1.3.ebuild
new file mode 100644
index 000000000000..0b4603541d4d
--- /dev/null
+++ b/sci-libs/pyshp/pyshp-2.1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
+HOMEPAGE="https://pypi.org/project/pyshp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" shapefile.py || die
+}