summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2024-04-14 16:34:47 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2024-04-14 16:37:38 +0200
commit75fd5e178add2341038133799f31a7a041249d9d (patch)
tree492c163e2959f868495a6c387747382b9692d722 /sci-libs/pyshp
parentsci-libs/opencascade: drop 7.7.1-r1 (diff)
downloadgentoo-75fd5e178add2341038133799f31a7a041249d9d.tar.gz
gentoo-75fd5e178add2341038133799f31a7a041249d9d.tar.bz2
gentoo-75fd5e178add2341038133799f31a7a041249d9d.zip
sci-libs/pyshp: Add support for Python 3.12
Closes: https://bugs.gentoo.org/929787 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'sci-libs/pyshp')
-rw-r--r--sci-libs/pyshp/pyshp-2.3.1-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/pyshp/pyshp-2.3.1-r2.ebuild b/sci-libs/pyshp/pyshp-2.3.1-r2.ebuild
new file mode 100644
index 000000000000..18fbf87fe491
--- /dev/null
+++ b/sci-libs/pyshp/pyshp-2.3.1-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
+HOMEPAGE="https://pypi.org/project/pyshp/"
+# pypi tarballs are missing test data
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/GeospatialPython/${PN}/archive/${PV}.tar.gz -> ${P}..gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ epytest test_shapefile.py -m "not network" || die
+}