summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2022-12-28 08:57:59 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2022-12-28 08:59:35 +0100
commitd7df09f4d5fe75cd338bf3fdbb9dc23cba4ae8cf (patch)
tree3ba9db3778d63521fae9c8007c6e7652b9b9e9a9 /sci-libs/pyshp
parentmedia-sound/abcmidi: bump to 2022.12.27 (diff)
downloadgentoo-d7df09f4d5fe75cd338bf3fdbb9dc23cba4ae8cf.tar.gz
gentoo-d7df09f4d5fe75cd338bf3fdbb9dc23cba4ae8cf.tar.bz2
gentoo-d7df09f4d5fe75cd338bf3fdbb9dc23cba4ae8cf.zip
sci-libs/pyshp: Bump to 2.3.1. Add python-3.11 support
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'sci-libs/pyshp')
-rw-r--r--sci-libs/pyshp/Manifest1
-rw-r--r--sci-libs/pyshp/metadata.xml1
-rw-r--r--sci-libs/pyshp/pyshp-2.3.1.ebuild27
3 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/pyshp/Manifest b/sci-libs/pyshp/Manifest
index 15f451117d67..eba883356fd9 100644
--- a/sci-libs/pyshp/Manifest
+++ b/sci-libs/pyshp/Manifest
@@ -1 +1,2 @@
DIST pyshp-2.1.3.tar.gz 219626 BLAKE2B 2da94cb4b1514a504b9f961b58add973a73dea641ad5867b670860000decd29af72092079b5d16f516b99a59be83028f4698faa2cb013200e533bbe772746d48 SHA512 249302e784bb38860037242b70899faaf504ef626c37decca44dc0d7c4f9482737e3234c0002393d1ef9800778715fc2b9946f3e3f3ecf507921e9db218d0d33
+DIST pyshp-2.3.1..gh.tar.gz 2213685 BLAKE2B ca5b87dec442508bc4a0612982984ba0fb91aa8acffddb6a448c43ccf42285305600a5e28e1fb781a3d94e8ce0624d027642fddcc5f2176dca3df095e59df170 SHA512 08844492b8d1d824c639844f7f314909d946bd4d3703a4f8d4cb64d400729671b42ff5b0f80aa68d9469f3939a3c7619ba13c9efdcba3b244ec01d7be3a371c5
diff --git a/sci-libs/pyshp/metadata.xml b/sci-libs/pyshp/metadata.xml
index 6635cddf96ed..698e51f02c5c 100644
--- a/sci-libs/pyshp/metadata.xml
+++ b/sci-libs/pyshp/metadata.xml
@@ -6,6 +6,7 @@
<name>Thomas Beierlein</name>
</maintainer>
<upstream>
+ <remote-id type="github">GeospatialPython/pyshp</remote-id>
<remote-id type="pypi">pyshp</remote-id>
</upstream>
</pkgmetadata>
diff --git a/sci-libs/pyshp/pyshp-2.3.1.ebuild b/sci-libs/pyshp/pyshp-2.3.1.ebuild
new file mode 100644
index 000000000000..af715dcb9263
--- /dev/null
+++ b/sci-libs/pyshp/pyshp-2.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{7..11} )
+inherit distutils-r1
+
+DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
+HOMEPAGE="https://pypi.org/project/pyshp/"
+# pypi tarballs are missing test data
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/GeospatialPython/${PN}/archive/${PV}.tar.gz -> ${P}..gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ epytest test_shapefile.py -m "not network" || die
+}