summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-11-24 09:24:40 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-24 09:33:01 +0100
commitee9832fca2073c27f072d913beffa107aba95b2c (patch)
tree6e52bfc3c3a12ccf6bed570c6395271cdb904c42 /sci-libs/qd/qd-2.3.17.ebuild
parentvirtualbox packages: Bump to version 5.0.30 (diff)
downloadgentoo-ee9832fca2073c27f072d913beffa107aba95b2c.tar.gz
gentoo-ee9832fca2073c27f072d913beffa107aba95b2c.tar.bz2
gentoo-ee9832fca2073c27f072d913beffa107aba95b2c.zip
sci-libs/qd: Version bump to 2.3.17
* EAPI=6 * Remove .la files when USE="-static-libs" * Add FMA CPU_FLAGS_X86 flags Package-Manager: portage-2.3.2
Diffstat (limited to 'sci-libs/qd/qd-2.3.17.ebuild')
-rw-r--r--sci-libs/qd/qd-2.3.17.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-libs/qd/qd-2.3.17.ebuild b/sci-libs/qd/qd-2.3.17.ebuild
new file mode 100644
index 000000000000..bc308bb91f78
--- /dev/null
+++ b/sci-libs/qd/qd-2.3.17.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+FORTRAN_NEEDED=fortran
+
+inherit autotools fortran-2
+
+DESCRIPTION="Quad-double and double-double float arithmetics"
+HOMEPAGE="http://crd-legacy.lbl.gov/~dhbailey/mpdist/"
+SRC_URI="http://crd.lbl.gov/~dhbailey/mpdist/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_x86_fma3 cpu_flags_x86_fma4 doc fortran static-libs"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.3.17-fix-build-system.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-ieee-add \
+ --disable-sloppy-mul \
+ --disable-sloppy-div \
+ --enable-inline \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4) fma) \
+ $(use_enable fortran)
+}
+
+src_install() {
+ default
+
+ dosym qd_real.h /usr/include/qd/qd.h
+ dosym dd_real.h /usr/include/qd/dd.h
+
+ if ! use doc; then
+ rm "${ED%/}"/usr/share/doc/${PF}/*.pdf || die
+ fi
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}