summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyangWu <xgreenlandforwyy@gmail.com>2022-03-23 22:22:16 +0800
committerBenda Xu <heroxbd@gentoo.org>2022-03-27 11:12:51 +0800
commit83c4bf0776b5e64867f547284ca794254dab36f7 (patch)
treeacebbb1938433d4e09442afab17980a411b360ff /sci-libs/rocFFT/files
parentsci-libs/rocBLAS: bump version to 5.0.2 (diff)
downloadgentoo-83c4bf0776b5e64867f547284ca794254dab36f7.tar.gz
gentoo-83c4bf0776b5e64867f547284ca794254dab36f7.tar.bz2
gentoo-83c4bf0776b5e64867f547284ca794254dab36f7.zip
sci-libs/rocFFT: bump version to 5.0.2
Enable benchmark and perfscript USE flags. Closes: https://github.com/gentoo/gentoo/pull/24726 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs/rocFFT/files')
-rw-r--r--sci-libs/rocFFT/files/rocFFT-5.0.2-add-math-header.patch12
-rw-r--r--sci-libs/rocFFT/files/rocFFT-5.0.2-unbundle-sqlite.patch54
2 files changed, 66 insertions, 0 deletions
diff --git a/sci-libs/rocFFT/files/rocFFT-5.0.2-add-math-header.patch b/sci-libs/rocFFT/files/rocFFT-5.0.2-add-math-header.patch
new file mode 100644
index 000000000000..1a35126f1d8c
--- /dev/null
+++ b/sci-libs/rocFFT/files/rocFFT-5.0.2-add-math-header.patch
@@ -0,0 +1,12 @@
+fix compilation issue: error: use of undeclared identifier 'ceil' 'floor'
+===================================================================
+--- rocFFT-rocm-5.0.2.orig/library/src/device/generator/stockham_gen_base.h
++++ rocFFT-rocm-5.0.2/library/src/device/generator/stockham_gen_base.h
+@@ -20,6 +20,7 @@
+
+ #pragma once
+ #include "stockham_gen.h"
++#include <math.h>
+
+ // Base class for stockham kernels. Subclasses are responsible for
+ // different tiling types.
diff --git a/sci-libs/rocFFT/files/rocFFT-5.0.2-unbundle-sqlite.patch b/sci-libs/rocFFT/files/rocFFT-5.0.2-unbundle-sqlite.patch
new file mode 100644
index 000000000000..4da2b2092906
--- /dev/null
+++ b/sci-libs/rocFFT/files/rocFFT-5.0.2-unbundle-sqlite.patch
@@ -0,0 +1,54 @@
+Disable rocFFT fetching SQLite3 and link to system libsqlite.so
+--- rocFFT-rocm-5.0.2/library/src/CMakeLists.txt
++++ rocFFT-rocm-5.0.2/library/src/CMakeLists.txt
+@@ -134,31 +134,7 @@ set( rocfft_source
+ rtcsubprocess.cpp
+ )
+
+-# SQLite 3.36.0 enabled the backup API by default, which we need
+-# for cache serialization. We also want to use a static SQLite,
+-# and distro static libraries aren't typically built
+-# position-independent.
+-include( FetchContent )
+-
+-# embed SQLite
+-FetchContent_Declare(sqlite_local
+- URL https://sqlite.org/2021/sqlite-amalgamation-3360000.zip
+- URL_HASH SHA256=999826fe4c871f18919fdb8ed7ec9dd8217180854dd1fe21eea96aed36186729
+-)
+-FetchContent_MakeAvailable(sqlite_local)
+-add_library( sqlite3 STATIC ${sqlite_local_SOURCE_DIR}/sqlite3.c )
+-set_target_properties( sqlite3 PROPERTIES
+- C_VISIBILITY_PRESET "hidden"
+- VISIBILITY_INLINES_HIDDEN ON
+- POSITION_INDEPENDENT_CODE ON
+- )
+-
+-# we don't need extensions, and omitting them from SQLite removes the
+-# need for dlopen/dlclose from within rocFFT
+-target_compile_options(
+- sqlite3
+- PRIVATE -DSQLITE_OMIT_LOAD_EXTENSION
+-)
++find_package( SQLite3 REQUIRED )
+
+ set_property(
+ SOURCE rtc.cpp
+@@ -170,7 +146,7 @@ prepend_path( ".." rocfft_headers_public
+ add_library( rocfft ${rocfft_source} ${relative_rocfft_headers_public} )
+ add_library( roc::rocfft ALIAS rocfft )
+
+-target_link_libraries( rocfft PRIVATE stockham_gen sqlite3 )
++target_link_libraries( rocfft PRIVATE stockham_gen ${SQLite3_LIBRARIES} )
+ if( NOT WIN32 )
+ target_link_libraries( rocfft PRIVATE -lstdc++fs )
+ endif()
+@@ -203,7 +179,7 @@ endif()
+ target_include_directories( rocfft
+ PRIVATE $<BUILD_INTERFACE:${PROJECT_SOURCE_DIR}/library/src/include>
+ $<BUILD_INTERFACE:${PROJECT_BINARY_DIR}/library/src/device>
+- ${sqlite_local_SOURCE_DIR}
++ ${SQLite3_LIBRARIES}
+ PUBLIC $<BUILD_INTERFACE:${PROJECT_SOURCE_DIR}/library/include>
+ $<BUILD_INTERFACE:${PROJECT_BINARY_DIR}/include>
+ $<INSTALL_INTERFACE:include/rocFFT>