summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-04-29 23:48:04 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-04-29 23:53:54 -0500
commit19089ede16991afb7044047e5848f21e0757d442 (patch)
tree803ea5840a8dbbb45b9cdb3afa24363a0616dff0 /sci-libs/scalapack/scalapack-2.1.0.ebuild
parentnet-vpn/wireguard-modules: bump to 1.0.20200429 (diff)
downloadgentoo-19089ede16991afb7044047e5848f21e0757d442.tar.gz
gentoo-19089ede16991afb7044047e5848f21e0757d442.tar.bz2
gentoo-19089ede16991afb7044047e5848f21e0757d442.zip
sci-libs/scalapack: version bump to 2.1.0
Closes: https://bugs.gentoo.org/511150 Closes: https://bugs.gentoo.org/675636 Closes: https://bugs.gentoo.org/684750 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs/scalapack/scalapack-2.1.0.ebuild')
-rw-r--r--sci-libs/scalapack/scalapack-2.1.0.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/sci-libs/scalapack/scalapack-2.1.0.ebuild b/sci-libs/scalapack/scalapack-2.1.0.ebuild
new file mode 100644
index 000000000000..a1979a20ad64
--- /dev/null
+++ b/sci-libs/scalapack/scalapack-2.1.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils fortran-2 toolchain-funcs
+
+DESCRIPTION="Subset of LAPACK routines redesigned for heterogenous (MPI) computing"
+HOMEPAGE="https://www.netlib.org/scalapack/"
+SRC_URI="https://www.netlib.org/scalapack/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/lapack
+ virtual/mpi"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ if use static-libs; then
+ mkdir "${WORKDIR}/${PN}_static" || die
+ fi
+ # mpi does not have a pc file
+ sed -i -e 's/mpi//' scalapack.pc.in || die
+}
+
+src_configure() {
+ scalapack_configure() {
+ local mycmakeargs=(
+ -DUSE_OPTIMIZED_LAPACK_BLAS=ON
+ -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs blas)"
+ -DLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs lapack)"
+ -DBUILD_TESTING=$(usex test)
+ $@
+ )
+ cmake-utils_src_configure
+ }
+
+ scalapack_configure -DBUILD_SHARED_LIBS=ON -DBUILD_STATIC_LIBS=OFF
+ use static-libs && \
+ CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" scalapack_configure \
+ -DBUILD_SHARED_LIBS=OFF -DBUILD_STATIC_LIBS=ON
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use static-libs && \
+ CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ use static-libs && \
+ CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" cmake-utils_src_install
+
+ insinto /usr/include/blacs
+ doins BLACS/SRC/*.h
+
+ insinto /usr/include/scalapack
+ doins PBLAS/SRC/*.h
+}